Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a publishing page. It is published. In my Current navigation I have pages checked. The page however is not being shown. Other pages are. If I create a custom link to the page it is shown. I can't work out why the page is not in the current navigation. What could be going wrong?

share|improve this question
    
Navigation is security trimmed. Does the page has unique permissions? Also, do you see the page in current navigation settings tree? –  Amit Kumawat Nov 11 '11 at 16:03
    
Same perms as other pages. Yes I do see the page in the current navigation settings tree. Just not being rendered in the display. –  John Nov 11 '11 at 16:06
    
On navigation settings, Please Check the max dynamic item limit as well, default is 20. If adding your page exceed the limit, it will not display –  Amit Kumawat Nov 11 '11 at 16:13
    
Please could you add this an answer –  John Nov 11 '11 at 16:24
    
Are you creating the publishing pages problematically? whether you UI or code its a manual process. I am assuming you have both publishing and team activated? –  Mary Rivers Nov 11 '11 at 17:03
add comment

1 Answer 1

up vote 0 down vote accepted

On navigation settings, Please Check the max dynamic item limit as well, default is 20. If adding your page exceed the limit, it will not display

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.