Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a page with two links that will open two different SharePoint modal dialog. Each of this modal dialog contains a SPGridView data control with Allow Filtering set to True. My problem is that only one of the spgridview is working fine, the other will throw a javascript error. In FireBug the error is CAMOpt is not defined. After comparing both spgridview I've found out that the visibility of the filter image is set to hidden. Please refer to the image below

Filtering image is not visible

Filtering image is visible

How can I fix this thing. Really appreciate any help. Thanks

share|improve this question

2 Answers 2

Sounds like an issue with the way that particular grid column is set up. What type of column is it and what it the datatype to which you are binding?

share|improve this answer
    
I don't think its about the column, because I have the same spgrdiview with the same column working fine on a normal page (not Modal Dialog) –  Agamand The True Nov 11 '11 at 6:15

accordingly to error with CAMOpt - make sure that js file that defines the function is referenced in popup, it seems to be - MENU.debug.js or MENU.js to build the menu.

Also the difference in visible/hidden is in filter option that is displayed when you mouse over the column.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.