Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Scenario: We have an authoring server that we do our content editing on for our SharePoint 2007 public website. We have a Content Deployment Path setup to deploy the content from the authoring server to the production server that external users access.

On the web application settings we have Anonymous Access enabled (for both environments) and on the site collection it is enabled as well. On the IIS web application for the production environment, anonymous access is enabled, but all other methods of authentication (Windows, etc.) are disabled. This works just fine on our other web applications.

Issue: On the authoring server, we can access the site anonymously just fine. However, after deploying the content to the production server, everything we try to access anonymously gives "Access Denied" or "401 Not Authorized".

What am I missing?

Update: I discovered the Alternate Access Map that I added for the public URL wasn't setup correctly and wasn't in the IIS bindings. Fixed both of those and now receive "You are not authorized to view this page", Error 401.1. Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Verify that everything used to make up your typical page has a published version. It is common to forgot about some things in certain areas like CSS/JS/Images in the /Style Library or page layouts in the Master Page Gallery.

If you have /PublishingImages that are being included, ensure that they have a published version as well.

share|improve this answer
    
I checked everything (Pages, Images, and Styles) and it is all checked in, published, and approved. –  John Chapman Nov 10 '11 at 21:29
1  
Every time I've run into this it was because something that was included in the master page or in the page layout was not being published. –  Dave Wise Nov 10 '11 at 21:50
1  
Though, another area to check is to make sure that the Anonymous user has permissions to the Style Library. They should but that does break occasionally –  Dave Wise Nov 10 '11 at 21:51
    
YOU ARE MY FAVORITE PERSON RIGHT NOW!!!! Ok, so I found that everything was set properly on the authoring side. However, the Anonymous Access setting for the Site Collection and Style/Master Page libraries didn't carry over during deployment. I had to login to the production side, set those permissions, and now it works. –  John Chapman Nov 10 '11 at 22:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.