Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a problem with user profile properties

We are not able to see a property on EditProfile.aspx because in Edit User Profile Property I checked the radio button"Do not allow users to edit values for this property" when I changed the check mark to radio button "Allow users to edit values for this property" it shows up on the edit profile page but what if we don't want the user to edit it, and still want to show it as text on the edit profile screen?

Please suggest if there is any way to do this.

Thanks,

share|improve this question

2 Answers 2

The way this works there are a couple of compound fields that determine the functionality.

Under the Display grouping there are options for where to show it. On the profile page, on the edit profile page, in the newsfeed. Then you also have the "Do not allow users to edit values for this property." option allow or disallow updates. If updates are not allowed, then this is non-editable text.

For a step by step with screenshots, here is a write up I previously created. http://www.mikeoryszak.com/sharepoint/user-profiles-%E2%80%93-creating-custom-properties

share|improve this answer

This property didn't show after setup radio button "Do not allow users to edit values for this property", because it hasn't value for this specific user (SharePoint is smart enough and hide from edit mode properties that you can't setup and that have empty value ). Try to setup value directly using Central Admin (Application Management -> Manage service applications -> User profile service application -> Manage), find and edit profile for your user, setup value for property that you want to hide, and check on user profile page that this property appear as read only on edit.

So, to make property read only on edit page, you must set "Do not allow users to edit values for this property" and check "Show on edit details page". Recently I faced with exactly the same problem :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.