Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a form that use SPServices and have a textarea field for user to insert multi rows data.

The data from the textarea can be successfully insert into the SharePoint 2007 column of type 'Multiple lines of text' as shown below

enter image description here

However, when I edit the item, it seems that the "multi-lines" have become a single line. (It display all the text inside from the textarea field as a single line and not exactly what is written on the textarea.)

Any Insight?

share|improve this question
add comment

1 Answer 1

Make sure that you escape the Rich Text that you send into the Web Service call. For example, HTML tags should look like

<table>

rather than

<table>
share|improve this answer
    
Hi Marc, how do I pass the textarea field as a Rich Text into Web Service Call? Would a JQuery Rich Text field (such as those listed in queness.com/post/212/…) help? (cause I was wondering if SPServices can take the values from a JQuery rich text field.) –  Larry Morries Nov 2 '11 at 2:00
    
I tried using one of the JQuery Rich Text and notice that this time, I am able to retrieve the Rich text in SharePoint 2007, but I was not able to insert any text into the SharePoint 2007. Any insight? –  Larry Morries Nov 3 '11 at 4:12
    
I just realized that the formatting was wrong on my initial answer. Does that help? –  Marc D Anderson Nov 3 '11 at 20:35
    
Hi Marc, it does not help cause right now, I see lots of gubbish content in my fields in SharePoint 2007 List. –  Larry Morries Nov 8 '11 at 9:11
    
What does the "gubbish" content look like? –  Marc D Anderson Nov 15 '11 at 10:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.