Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Brand new SP 2010 install patched up to August 2011 CU. When we edit the navigation tab menu entries, We can't set an audience. If I search for Owners we get no exact match was found. If I use the address book it finds it, but never resolves it or other sharePoint groups after selecting them. What is up with this? We were able to import some 18,000+ user profiles.

share|improve this question
    
I've noticed that 2 sites that I migrated over the last couple of months have this issue as well. They were both migrations. The symptoms seem to be user profile service related. One site has a nightly user profile import, we can see the user in the UPS database and he is in a group associated with the audience, but never actually appears in the audience. As an alternative we attempted to target the web part with the SharePoint groups available and get this 'no exact match was found' error as well. We are running the August 2011 CU build. Is it a particular bug with this build perhaps? –  pigeon Feb 3 '12 at 6:08
    
Do you get this on all groups? I have seen some strange issues on some servers freaking out if the audience search returns more than one result. If you try and create a group like, "uniqueTest" and try and add it to the Audience, is the error still there? –  Anders Aune Feb 26 '12 at 17:19

1 Answer 1

I take it you use security groups for your audience (memberOf)?

If so, you need to import those security groups as well in your user profile synchronization connection, as the sync both handles users and SG (for audiences).

share|improve this answer
    
I'm trying to use SharePoint Groups like "owners" in the audience. I've done a full impoort of AD and run full search index, but did not help. I am able to select those groups from address book, but error persist. Thanks –  cyberpine Oct 31 '11 at 20:00
    
I never got groups and distribution lists to work. I always use compiled audience rules. –  Anders Rask Oct 31 '11 at 20:05
    
the features works prefectly in 2007 and it's the only type of groups we would want users updating so we use it alot. I notice If i select the group using the address book it selects it.. but same error. but if I hover over it says unalbe to validate and displays an object reference error. This must be some sort of bug. –  cyberpine Oct 31 '11 at 20:11
    
Are we saying you can no longer user SharePoint groups in Audience target? technet.microsoft.com/en-us/library/cc261958.aspx –  cyberpine Nov 15 '11 at 17:43
    
all i'm saying is that I always stick to compiled audience rules –  Anders Rask Nov 15 '11 at 19:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.