Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a custom Sharepoint 2007 publishing portal site definition with custom content types for the different page layouts. When editing a page (either in the root of the site or a subsite) using a custom layout from the main "Manage Content and Structure" tree view, the page content type is fine, but if I view the page directly and edit it from the edit bar option Page->Settings and schedule, the content type gets stripped and replaced with "Page." I can change it back by viewing and editing it from the main "Manage Content and Structure" list, but not from its subsite home location.

share|improve this question
add comment

3 Answers

You might need to make sure that your custom content type has been explicitly added to the pages library. You can do this manually, or automatically with a content type binding element in a feature, or within a feature receiver.

share|improve this answer
add comment

Hmmmm. I haven't seen this problem, but try editing the properties of the page in the Pages library. See if that keeps it from changing content types.

share|improve this answer
add comment

I have this same issue. If I edit the page's properties and save it, then edit the page itself, the content type sticks. It's like the content type isn't REALLY associated with the page or something. Oh, the pages library does have the content types added. It still has the issue though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.