Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm getting an error on SP2010 while editing a custom master page: When any user who doesn't have administrative (Full Control) rights tries to access the site, it gives "Access denied". This page talks about the problem: http://grounding.co.za/blogs/neil/archive/2008/05/15/access-denied-on-a-sharepoint-site-when-editing-master-pages.aspx

The problem has to do with the master page being unapproved while being edited. Is there a way to disable the approval process on the master page? Is this a good idea? What do folks usually do to solve this problem?

Thank you :)

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The masterpage gallery is default hidden in browser, so what you need to do is:

  1. Open site with sharepoint designer
  2. Go to the masterpage gallery
  3. Click on List settings
  4. Deselect "Require content approval for submitted items" in the Settings

(You can also choose to unhide this list in browser)

I would only use removing the approval process while developing the masterpage. When changes are made, the users will see this automatically. Allowing approval gives you an extra security check. When something changed "by accident", you can always undo without the users ever noticing (because you won't approve the masterpage then...).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.