Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In internet explorer 9 i have error when trying to save list item.

Namespace prefix 'xsd' is not defined.

Before that i have javascript error inside some sharepoint files. This error says really nothing.

System.InvalidOperationException: Namespace prefix 'xsd' is not defined.    at System.Xml.Serialization.XmlSerializationReader.ToXmlQualifiedName(String value, Boolean decodeName) 
share|improve this question
1  
Has this page been modified in Designer by chance? –  Dave Wise Oct 26 '11 at 16:15

3 Answers 3

up vote 5 down vote accepted

This seems to be a problem with the SharePoint client-side code, possibly as a result of changes to support branding. I have also seen it when trying to save a page I have edited. Your choices are:

1) Set your browser to use IE8 standards - you can do this by using F12 to get the IE developer tools panel and setting Document Mode to IE8 standards in the developer tools menu/ribbon thing.

2) Add the meta tag: to your master page. This will force the browser to use IE8 Standards.

There is a little more detail in my blog article.

share|improve this answer
1  
We have had this same issue when trying to add support for some components of HTML5 and CSS3. This is exceptionally unfortunate as we want to use <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /> but apparently cannot. So much for "full support" of IE9. –  Robert Kaucher Nov 7 '12 at 15:50
    
IE 11 fails no matter what, but Chrome 34 works fine (though it adds the user twice). –  Cees Timmerman May 21 at 15:08

To fix this, and thus making my SharePoint Site very bland I change back from IE=9 to..

<meta http-equiv="X-UA-Compatible" content="IE=8" />
share|improve this answer

This was problem with people pick up field! In IE9 if "compatibility view" not set on localhost we will have such error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.