Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am getting a weird error in the UAT environment for the word automation services. I am getting the following errors in the logs while adding the jobs for conversion.

  • SharePoint Foundation Topology 8077 Critical "There are no instances of the Word Automation Services started on any server in this farm. Ensure that at least one instance is started on an application server in the farm using the Services on Server page in Central Administration."
  • Unknown Custom 0000 Unexpected "No endpoints were found for the service application. Ensure that the service has been enabled on one or more servers within the SharePoint farm.

The error is pointing to service application not configured or online which weird because I have configured it and the status of the service is online as per PS command as shown in the link here.

I have tried deleting and recreating the service, restarted the server but the error still remains.

Has anyone encountered such kind of an error? Any resolutions?

Thanks,

Soju

share|improve this question
add comment

1 Answer

Try to open SharePoint Central Administration -> System Settings -> Manage Servers in this farm. There are a list of running services. Check that word automation services is running. If not, go to the Central Administration -> System Settings -> Manage services on server and run this service.

share|improve this answer
    
I have verified the places mentioned and found that the Word Automation Services is missing in both places. I also found that it is missing from list from the PS command Get-SPServiceInstance. Looks like someone has accidentally deleted the Word Automation Services instance on the server. How do I add that back? –  Soju Oct 26 '11 at 10:26
    
I reinstalled the services using the command. psconfig.exe -cmd services -install. And now the Word Automation Services is available in the list. @Alexander Thanks for your help, it has helped me in resolving the issue. –  Soju Oct 26 '11 at 10:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.