Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created workflow. In the workflow I used the "start task process on current item with these user" action.

my problem: the user do not receive any email/task notification.

in the "edit task page" I enter to the "Change the completion condition for this task process" and insert the "Email this user" action. my problem: also in this task the user do not receive any email notification.

If I operate action like "collect data from this user" the user indeed receive an email notification.

share|improve this question
    
Asking the obvious, just to get it out of the way :-). Is Outgoing email setup complete? If users setup alerts in any other list on the same site collection do they get alert emails? –  sumitkm Oct 23 '11 at 21:59
    
I do not know how to test the email alert... but the user is getting an announcement to there email if I operate the "collect data from user" action etc.... is it answer your question? –  liron Oct 24 '11 at 7:27
    
Okay, so it's certain that outgoing email is working. Sepaka seems to have some good suggestions below. Do let us know if it solves your problem. We'll do the method of elimination :) –  sumitkm Oct 24 '11 at 10:27
    
the workflow is associated to particular list and I define the workflow to be operate manually. what else can I do in order to solve this issue? –  liron Oct 24 '11 at 11:41
add comment

2 Answers

follow these steps to solve the notification issue / problem with the Task process in SharePoint 2010 workflow (share point 2010 designer) (this apply to the custom task process too) :

on the main workflow designer (2010) page click "Edit Workflow"

then on the next page where you see all your workflow steps point to the step which has the task process, a small drop-down arrow appear on the right end of the step, click this arrow a pop up menu will show, click on the "Properties".

a properties tab will open, showing additional properties for that task process, there are two properties you need to set in order to start receiving the notification emails:

  1. SendDefaultTaskNotifications : change to Yes (default will be No)

  2. TaskProcessOwner : set the task process owner (mostly will be the person or group that assigned in this process).

share|improve this answer
add comment

I assume, you are using SPD workflows. I have had a similar situation where my workflow doesn't send out emails but I managed to get working.

One question for you, this would help me understand your situation better.

** What is being displayed on the workflow history?

Cheers, Sepaka

share|improve this answer
    
in the workflow histort I see the next line: "There are no items to show in this view of the "Workflow History" list. To add a new item, click "new" ". I lookout to be answer. –  liron Oct 24 '11 at 7:33
    
Try to create new item on the list, and click on item --> workflows, on the ribbon. See what's the status of the workflow. Did you choose your workflow to start manually or automatically when a new item is created? –  Sepaka Oct 24 '11 at 7:52
    
I choose to start my workflow manually. when I click on item (the new item) --> workflow, I see that there is no running workflow –  liron Oct 24 '11 at 8:02
    
Are you absolutely sure that the workflow is associated/attached to that particular List/Library? Click on Library/List on the ribbon, then click on Workflow Settings, a dropdown will appear. Select "worklflow settings". You should be able to see if your workflow is attached to your library/List. One more thing, you said you choose it to be started manually, please confirm that you started immediately after creating new item. To do this, on your newly created item, hover over it, select workflows, select your workflow.Should start it or give you a window with a "run" workflow button. –  Sepaka Oct 24 '11 at 8:24
    
the workflow is associated to particular list and I define the workflow to be operate manually. what else can I do in order to solve this issue? –  liron Oct 24 '11 at 11:40
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.