Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a problem with search alerts in my SharePoint 2010 application. It's look fine when I click "Alert me" button on the search page. But when I look in the list with my alerts it doesn't show up. All other alers on the page works fine. Before we have problem with alerts on the Post list. But it was fixed after an installation of a HotFix. We using a blog site.

What is wrong and how to fix it?

share|improve this question

migrated from stackoverflow.com Oct 20 '11 at 10:18

This question came from our site for professional and enthusiast programmers.

1 Answer 1

What type of authentication are you using? Search Alerts are not supported with claims based authentication.

Edit-

  • I don't believe the option should be available otherwise, but you should double check the Search app and ensure alerts are enabled, and try disabling / re-enabling it.
  • Are there any email errors in the ULS?
  • Verify you don't have timer jobs that are failing.
  • I've seen this before with 2007 (in regards to inconsistent alerts), in one instance it was an inconsistent farm state. Re-running the
    configuration wizard on each server solved that issue (assuming the same patches are already applied to all your servers). In the other, Exchange did not have the machine running the timer job included as an approved relay.
  • Your server anti-virus/malware, most packages now have some sort of protection against mail worms and will block port 25. Sometimes, this is outright (not your case or it wouldn't work at all), and sometimes it will only do so after it meets a certain thresh hold. The AV logs should tell you if this is happening. Ditto for third party host firewalls.

If I can think of any other items I'll edit the post and place them here.

share|improve this answer
    
I using standard windows authentication. –  Daniel Oct 21 '11 at 5:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.