SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created a "Hello World" ribbon button as per MSDN code sample:

The "Hello World" ribbon button is working only in AllItems.aspx (i.e. In the left navigation pane, click "Shared Documents" to open the Shared Documents library.). However, the "Hello World" ribbon button is not visible in the following scenarios:

  1. "Shared Document" on the homepage (i.e home.aspx) - At Home.aspx, edit page, click on "Insert" tab, click on "Existing List" and then add "Shared Documents" list into the page.
  2. "Shared Document" on any site page - Create new site page, click edit page, click on "Insert" tab, click on "Existing List" and then add "Shared Documents" list into the page.

I have full permissions to the site, however the "Hello World" ribbon button is still not visible to me. Is this a SharePoint bug?

share|improve this question

I'm not sure but it can be because of settings of ListViewWebpart on your page. If the toolbar in this webpart settings is set to Summary mode the Ribbon customizations for the underlying list will not be displayed on page. You need to set it to Full mode.

share|improve this answer
Setting the toolbar to Full did it for me. – Luis Jan 6 '14 at 23:56

It sounds like you've created a Ribbon Custom Action which only attaches to Lists (see RegistrationType=List), and not Web Part Contextual Groups. When you add the Shared Documents view to a page, it's added to a Web Part.

You'll need to look at adding your button to the Contextual Tab Group for the Web Part as well as the List itself. Here's lots of info on MSDN about Contextual Tab Groups: and also on Chris O'Brien's blog:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.