Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I enabled Barcoding on one of the list in Sharepoint by going to Settings> Information Management Policy Settings > .. . There were already some list items in the list and as soon as I enabled barcoding, unique barcodes were assigned to each list item.

Now the other team doesn't want barcodes.. for now. So I disabled barcoding back. I thought disabling barcode would remove the 2 fields Barcode and Barcode Value from the list. But I still see Barcode field when I open a list item. The items still have a barcode. I checked out Content types - both barcode feilds are gone, but when I open views I still have an option to include it in view and it still appears in list items.

How do I get rid of Barcode completely ?

Thanks !

share|improve this question
add comment

migrated from stackoverflow.com Oct 19 '11 at 11:53

This question came from our site for professional and enthusiast programmers.

2 Answers

Do the fields appear under the Columns list in List Settings? If so, delete them manually from there.

share|improve this answer
    
Thanks guys ! @Rawbert - I indeed checked content types under list settings. Not there either. From what I found out in my research is that Barcodes becomes meta data of list once enabled. So when I enabled it , Barcode became meta data of all EXISTING list items. So I think it is like Title of a list item then. You can edit the name of title column, but you cannot delete it. Does that mean I cannot delete barcodes from 200 items I have ? Even if I can't remove it completely, I still don't want Sharepoint to recognize list items with that Barcode value. Thanks again guys ! –  user1001752 Oct 19 '11 at 19:37
add comment

You probably checked the site content type when you checked the content type. Site content types are templates that get stamped on the list when you apply them. So, the thing to check is the list content type and remove it from there.

share|improve this answer
    
Also that the list content types are visible in List Settings (obvious as it might sound, still often overlooked). –  James Love Oct 19 '11 at 16:44
    
@James - Thanks ! Neither Barcode / Barcode value fields show up in column list. But it still shows up when I try to create a view. Strange ! –  user1001752 Oct 19 '11 at 19:37
    
Turns out those are hidden/sealed, presumably because it's not quite clear that if you disable barcodes for new items you also want to delete them from existing ones. You'll have to write code/powershell to remove those fields forcefully. –  Rawbert Oct 20 '11 at 0:58
    
Here is a potential answer. Haven't tried the code yet, don't know how safe it is. social.technet.microsoft.com/Forums/en-US/sharepointadmin/… –  user1001752 Oct 20 '11 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.