Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I asked this on stack overflow, and they recommended I ask here instead.

I am trying to create a custom version of SharePoint's OpenDocuments control following an article on the MSDN sharepoint blog. Trying to use what is in that article doesn't seem to work for setting the registry on my machine to allow my control to appear. I want to be able to have the Edit Document menu appear just like with the AdobeAcrobat.OpenDocuments or SharePoint.OpenDocuments options, but I cant get sharepoint to recognize that the client has an acceptible program installed. Any help about what registry keys need to be set would be appreciated.

I first tried following the article exactly, then I tried setting all the same Registry entries that Acrobat set, but to no avail. The DLL is in the directory referenced by the Registry Keys. What did I miss?

REGEDIT4

[HKEY_CLASSES_ROOT\Koz.OpenDocuments.1]
@="Koz.OpenDocuments"

[HKEY_CLASSES_ROOT\Koz.OpenDocuments.1\CLSID]
@="{0BB18692-36A3-4324-B1B4-A353F0DFE648}"

[HKEY_CLASSES_ROOT\CLSID\{0BB18692-36A3-4324-B1B4-A353F0DFE648}]
@="Koz.OpenDocuments"

[HKEY_CLASSES_ROOT\CLSID\{0BB18692-36A3-4324-B1B4-A353F0DFE648}\InprocServer32]
@="mscoree.dll"
"ThreadingModel"="Both"
"Class"="Koz.OpenDocuments"
"Assembly"="Koz, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fcb03c2826a13954"
"RuntimeVersion"="v2.0.50727"

[HKEY_CLASSES_ROOT\CLSID\{0BB18692-36A3-4324-B1B4-A353F0DFE648}\InprocServer32\1.0.0.0]
"Class"="Koz.OpenDocuments"
"Assembly"="Koz, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fcb03c2826a13954"
"RuntimeVersion"="v2.0.50727"

[HKEY_CLASSES_ROOT\CLSID\{0BB18692-36A3-4324-B1B4-A353F0DFE648}\ProgId]
@="Koz.OpenDocuments.1"

[HKEY_CLASSES_ROOT\CLSID\{0BB18692-36A3-4324-B1B4-A353F0DFE648}\Implemented Categories\{62C8FE65-4EBB-45E7-B440-6E39B2CDBF29}]
share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

After getting in contact with the author of the website I mentioned, I managed to debug some more of the issue. It turns out that I changed stuff and it ended up with a new PublicKeyToken. Once I fixed that in the registry files, my changes worked correctly.

The article is a great starting point, and I have managed to create a very detailed process that happens and an interceptor between sharepoint and the AcrobatX openDocument control.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.