Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I currently have a QuickTime player on my site just below the global navigation. When I hover over some of my dropdown navigation items, their dropdowns goes beneath the QuickTime player.

What would be a valid solution to this?

share|improve this question
2  
I suspect it is the same problem as with flash-movies in a page: stackoverflow.com/questions/123529/… –  Dribbel Oct 18 '11 at 9:53

2 Answers 2

up vote 2 down vote accepted

You should be able to resolve this by setting a higher CSS z-index on your drop down nav elements. Note that for better cross-browser compatibility, you should also assign a lower z-index to the QuickTime player itself. In some scenarios, z-index must be assigned on both elements to ensure they are layered consistently as expected.

share|improve this answer

I'm sorry this response will be bereft of implementation specifics however I remember being briefed on a similar-sounding bug with drop-downs in I.E. falling behind in-line content. It was solved by placing the drop-down within a span element.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.