Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've set up an override CSS file and it's sitting in a Site Asset library.

When I view the file via SharePoint, it opens in my system default CSS editor - being my text editor of choice. This app is set as the default handler for the CSS extension in my Windows profile.

However, when I've checked-out the file then try to open it, it opens in SharePoint Designer 2010. Which is strange because the link clicked is exactly the same whether the file is checked out or not...

I've also fiddled with some options in SharePoint Designer 2010 to try and turn off this 'feature' but with out any luck.

How can I stop this behaviour and have CSS files handled only by the app I wanted?

Thanks.

share|improve this question

1 Answer 1

SharePoint 2010 provides office integration (SharePoint designer is one of the office application).This feature helps to manage(check-in, publish etc) files straight from the office application itself. Other applications apart from office may not provide this functionality,so you may need to manually save and check-in your file changes.

This feature can be turned off by changing Permissions available to Permissions levels(like Full control,Design, Read etc) at web application or site collection level (or any level which has its own permission and does not inherit them from parent)

The exact Permission you need to change for relevant Permission Level is :

"Use Client Integration Features - Use features which launch client applications. Without this permission, users will have to work on documents locally and upload their changes."

To change at Site Collection level: Site Settings>Site Permissions>Click Permissions Levels>Click the permission level you want to edit>Uncheck "Use Client Integration features">Save

To change at Web Application level :Central Administration>Application Management>Manage Web Applications> Select web application>Click 'User Permissions' from the ribbon>Uncheck "Use Client Integration features">Save

share|improve this answer
    
Thanks for the reply. I'm not sure the solution will fit my scenario as while I'm going through with the initial theming, I have 'full control' permissions - and that permission level can't be modified. For future reference, would disabling that flag cause all intranet file content (i.e. office suite files, CSS, images) to be downloaded (or otherwise handled) by the browser instead? Thanks! –  Beeblebrox Oct 19 '11 at 1:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.