Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Having recently migrated from MOSS 2007 to MOSS 2007 x64, we are having problems connecting to the Windows Authenticated (NTLM) authoring site using IE7.

The domain name is exactly the same but the IP address has changed as we have moved servers.

The site now runs in IIS 7.5 and uses an application pool running in Classic mode. When accessing the site in IE7, we are constantly asked to re-enter our login credentials. Eventually, parts of the site start to appear until after several login attempts, it hangs on a blank page.

Does anyone have any experience of this and how to rectify it? Interestingly, changing the IIS authentication mode to "Digest" rather than Windows Authentication seems to resolve the issue for IE7 but results in repeated login requests in other browsers.

share|improve this question
add comment

3 Answers 3

Do you have a proxy server? I've seen this happen in an environment where there was a proxy server but there was no exclusion for SharePoint URL.

You can check this:

Internet Options > Connections tab > LAN Settings button (Are you using a proxy server?)

Advanced button > Exceptions (Is your SharePoint URL listed?)

share|improve this answer
add comment

Is this the same on all computers? For login prompt issues in IE, the first place I typically look is at the IE settings.

The site should be listed as an Intranet site or at least a Trusted Site.

In addition, you should click the Advanced Tab and scroll down to the Security grouping and ensure that "Enable Integrated Windows Authentication" is accepted. I believe in IE7, there used to be a setting that would only allow it to sites in Intranet Zone.

With that said, an interactive login should work. I've seen multiple prompts come up though in cases where there are resources pulled from different URLs so the user has to authenticate to each of them.

share|improve this answer
    
Thanks for your response. Yes, it's the same on all machines running on the local intranet. The settings are all locked-down and always have been and any "Trusted Site" or "Intranet" zone settings which are defined will be domain specific (note that the domain has not changed). –  Ioan Oct 14 '11 at 13:56
add comment

Please validate that the virtualroot for that application has valid credentials and that application pool that this site runs under has proper permissions (you can test it in IIS Manager under Sites Tree - Basic Settings (for your site) and Test Settings Option.

Please also check Authentication option (expand Sites, select your site, switch to Features View and go to IIS - Authentication icon). You should see if your prefered authentication is enabled there (probably Windows Authentication).

If your site works from external workstation, but gets 401 on server, you need to Disable Loopback Check: http://support.microsoft.com/kb/896861

share|improve this answer
    
Thanks for your response. Yes, we have successfully tested access to the virtualroot. It seems odd that the problem only affects IE7 on the intranet (and not externally). Windows Authentication is also enabled for the site. The site in fact works fine from the local server too! –  Ioan Oct 14 '11 at 13:59
    
I start to understand, can you please verify if one of the workarouds will work? Try to 1) Open IE7 as Administrator (Run as Administrator) or 2) Open IE7 64-bit version. Let me know if any of these would work, then it'll be easier to find the cause. –  S. Delost Oct 14 '11 at 14:04
    
Thanks again - unfortunately the internal networked machines are locked down and are running in a 32-bit enironment with Windows XP and IE7. –  Ioan Oct 14 '11 at 15:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.