Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a public-facing SharePoint Foundation 2010 site managed by a hosting company, so I don't have access to the 14 hive, web.config, Central Administration, etc. The site is a standard Team Site, so my home page URL resolves to /SitePages/Home.aspx.

I wanted to keep anonymous users from seeing All Site Content, etc. so I changed anonymous access from "Entire Web Site" Web to "Lists and Libraries", and gave anonymous users View Items access to all lists on the home page. If I open the page as "www.mysite.com/SitePages/Home.aspx", I can see everything. However, if I just type in "www.mysite.com", I get prompted for a log in. When anonymous users had access to "Entire Web Site", everything worked fine (except, of course, for them being able to see All Site Content.

What is the correct way to set up anonymous access for a SharePoint Foundation 2010 site?

share|improve this question
add comment

2 Answers

The login issue you are facing might be due to either the master page, page layout, or any content that is not checked in and published. Publish it and verify again.

There are also licensing issues which you would like to check before implementing SharePoint Foundation for public facing sites. Its not the same way as it goes for MOSS or WSS. Please check this post - http://stackoverflow.com/questions/3511952/sharepoint-2010-foundation-licenses/3511977#3511977

share|improve this answer
    
I'll take a look, but that would probably mean an anonymous user couldn't see SitePages/Home.aspx either. Thanks. Also, since I am using a hosted SharePoint site, do I need to worry about licensing? That's the host's concern, not mine. –  CigarDoug Oct 14 '11 at 11:11
    
Normally, if the welcome page is configured to SitePages/Home.aspx in the Site settings, even though you type "www.mysite.com" it should lead you to "www.mysite.com/SitePages/Home.aspx". Its kind of wierd in this case. Just try out the different options and do let me know. The licensing part was added as an info for anyone who checks this post in the future. :) –  Deepu Nair Oct 14 '11 at 11:35
add comment

While you don't have access to run commands on the server, the hosting company does and should support this.

stsadm -o activatefeature -url -filename ViewFormPagesLockDown\feature.xml

http://technet.microsoft.com/en-us/library/cc263468(office.12).aspx#section6 http://sharepointsharpener.wordpress.com/2008/08/28/viewformpageslockdown-does-not-kick-in/

share|improve this answer
    
Thanks for suggesting this, unfortunately that command only works for SharePoint Server 2010, not SharePoint Foundation 2010. –  CigarDoug Oct 31 '11 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.