Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I try to publish a new master page in SharePoint Designer 2010, the publish options are missing.

no 'publish' menu option

Also, I can't do anything from the Master Page gallery within SharePoint as the needed options are greyed out:

greyed out

Troubleshooting thus far:

  1. In central Administration | SharePoint Designer Settings | All services are enabled

  2. Site Actions | Site Settings | Site Collection Administration | SharePoint Designer Settings | All services are enabled

  3. I am Site Collection Administrator

  4. SharePoint Server Publishing and SharePoint Server Standard site features are active

  5. In Library settings | Versioning settings, 'require content approval for submitted items' and 'create a version each time you edit an item' are both turned on

Any suggestions as to what else to check?

Thank you!

share|improve this question
add comment

2 Answers

Simple answer , but could be the reason.

Is the MasterPage checked-in with Major Version Or Minor ??

share|improve this answer
    
I'm not quite sure. Does it only become a Major Version once it's published and since I don't have that capability, would it be considered Minor? –  user4747 Oct 19 '11 at 12:17
    
Its the other way, only a Major version File(Master page) can be published , go to the master page gallery and check the version history. check-in into Major Version and then publish. –  Vamsi Oct 19 '11 at 13:47
    
I can check-in but no option to check-into a Major Version and publish. When I click on the page, it opens up Library Tools->Documents tab and all but 3 options are greyed out. link. The others report "This control is currently disabled. You might not have the right permission level to use this, you might need to select an object or item, or the control might not work in this context." I can't select an item. When right click an item link –  user4747 Oct 19 '11 at 15:49
    
Seems like a permission issue from screen shot, Even the "New Document" option is disabled Could you please check the permission of the logged in user, I know you have mentioned as "Site collection Admin" ; but I guess the permission model might have been broken for this library. can you perform the following steps and let me know the results. -> Goto the Master page Gallery....... -> Goto on Library -> Library Permissions....... -> Click on Check Permissions Options and enter the logged in the User ID , then click "Check Now" and let us know the results ( Screen shot would be great) –  Vamsi Oct 19 '11 at 16:48
    
Sure - we had checked that for both myself and Farm Admin (different results for permissions however same results when we tried to Publish - i.e. same greyed out options) and everything appeared ok. Here's the screenshot for my permission check: My Permissions –  user4747 Oct 20 '11 at 11:55
add comment

You might not have enabled the "SharePoint Server Publishing Infrastructure" feature in SharePoint 2010. Enable this feature in Site collection feature

share|improve this answer
    
Thanks Paddy but I just checked and it was enabled. –  user4747 Oct 14 '11 at 17:12
    
"SharePoint Server Publishing Infrastructure" must be activated on the site collection and the actual subweb you're working with, is it set in both places (two separate features, one in Site Collection Features and one in Site Features). –  webdes03 Oct 18 '11 at 18:53
    
Yes, thanks. It's activated in both places (under Site Collection Administration -> Site Collection features as well as Site Actions -> Manage site features). –  user4747 Oct 19 '11 at 12:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.