Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I want to open the site up for public viewing, which I've done by going Site Permissions -> Anonymous Access -> Entire Web Site

The problem is, I have some sub-sites because I wanted a drop down navigation, but none of those can be accessed anonymously - they don't show in the navigation area, and if I try to go directly to a page when not logged on, it'll ask for login details and then throw up a '401 UNAUTHORIZED' error.

I've tried going into the permissions of the sub-site, and it says it's inheriting permissions from the parent site, but it mentions nothing about anonymous access! :(

Any help would be much appreciated, thank you

share|improve this question

1 Answer 1

up vote 5 down vote accepted

This is typical when the site collection is a publishing site.

Check out http://blogs.msdn.com/b/russmax/archive/2010/01/22/lockdown-mode-in-sharepoint-2010.aspx

To determine if a site has ViewFormPagesLockdown enabled run the following:

get-spfeature -site http://sitecollectionURL

If ViewFormPagesLockDown is listed, it's enabled.

To toggle lockdown mode to off:

$lockdown = get-spfeature viewformpageslockdown

disable-spfeature $lockdown -url http://sitecollectionURL

If anonymous is already setup, you may need to disable\re-enable anonymous on the site.

HTH

share|improve this answer
    
Many thanks both for this, I've never used STSADM/Powershell (I only have design access) but will look into it and can hopefully turn this feature off. Thanks again –  xn dx Oct 11 '11 at 17:28
    
i have the same problem as well. When i create the web application the anonymous access was enabled only to the top level site. I did what the answer suggests, however i still have my subsites locked from anonymous access. The web application also uses claims based authentication. Could this be affecting it, because in another web application with windows only authentication, the solution worked just fine... Thanks in advance Tolis –  user6637 Feb 28 '12 at 9:10
    
I did what the answer suggests, but still same problem. Any Solution? Thanks –  Feroze Apr 10 '12 at 7:04
    
@Feroze please post a new question for your problem, it'll give it the attention it deserves –  David Lozzi Apr 10 '12 at 12:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.