Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Restore-SPSite : Access Denied
You do not have permission to perform this action or access this resource.

This is the error I get when trying to restore a Site Collection backup from the integrated development environment to my personal development environment. At this point I am unable to nail down the issue and it's driving me mad! Thoughts anyone?

I am logged in with Administrator privileges both for the Farm and Domain.

Thanks in advance.

Scott

UPDATE 1

Thank you all for your quick responses!

I should have mentioned this in my prior submission. I have successfully performed this action with the same site collection backup on domain c (a different CloudShare environment).

So, let me provide some more context:

  1. Backup of site collection is from domain a
  2. I'm trying to restore the site collection on domain b (CloudShare Environment)
  3. I have verified that both Farms have SP1 and June 2011 CU applied.
  4. On domain b I am able to do the following: backup a site collection, create new content databases, and create site collections from Powershell using the same account used to restore the site collection.
  5. I have tried creating a new content database within the web application and specifying the new database name in restore parameters. I have used the -force parameter with no success.
  6. I've looked through the Event Viewer logs, SharePoint logs, and even used SQL Profiler to see what is going on with no hint of where it's complaining.

The very first time I try to run this command it does start the process and runs for a minutes and then I get this error. Subsequent tries, it fails immediately.

Does anyone have some suggestions of where else to look or what specifically I should be looking for? I would expect that there's an issue with permission against a database but this account has dbo permissions on the content database and the SP Config DB. Any additional thoughts or comments would be greatly appreciated!!!

Here is the latest error after I've created a blank site collection from Central Admin and then tried to restore over top of it using the -force parameter.

PS C:\Users\Administrator> restore-spsite -identity http://sp2010/apps/procedures/sites/pps -path C:\temp\20111010091_spdd-dev08.bak -force

Confirm Are you sure you want to perform this action? Performing operation "Restore-SPSite" on Target "http://sp2010/apps/procedures/sites/pps".
[Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"): y Restore-SPSite : The operation that you are attempting to perform cannot be completed successfully. No content databases in the web application were available to store your site collection. The existing content databases may have reached the maximum number of site collections, or be set to read-only, or be offline, or may already contain a copy of this site collection. Create another content database for the Web application and then try the operation again. At line:1 char:15 + restore-spsite <<<< -identity http://sp2010/apps/procedures/sites/pps -path C:\temp\20111010091032_spdd-dev08.bak -force + CategoryInfo : InvalidData: (Microsoft.Share...dletRestoreSite:SPCmdletRestoreSite) [Restore-SPSite], InvalidOperationException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRestoreSite

Thanks! Scott

share|improve this question
    
Make sure 1) You have satisfy permission requirements as documented technet.microsoft.com/en-us/library/ee748655.aspx and 2) you choose "Run As Administrator" for Powershell snapin. –  Ashish Patel Oct 11 '11 at 2:45
    
Im pretty sure this is it too. You should set it as answer not comment –  Anders Rask Oct 11 '11 at 6:05
    
also make sure that both accounts actually have the same name (i.e. domain\Administrator) and not just administrator provileges. –  int32 Oct 11 '11 at 9:07

4 Answers 4

Can you access Central Administration? I'd check under Application Management > Manage Content Databases. In this screen:

  • Limits on the number of number of site collections allowed per content database are set.
  • Also in this area, databases can be set to 'Offline'. This can be confusing, it means that the database will still serve content, but new Site Collections can not be created within it.

If via power shell, you can create a new content db, you can target and your restore operation at that database. It may be worth a try:

http://technet.microsoft.com/en-us/library/ee748655.aspx

I don't know whether CloudShare offers Central Administration access.

The last half of this article offers ideas on using powershell to find Content Database information: http://msmvps.com/blogs/shane/archive/2011/04/28/powershell-doesn-t-show-all-of-your-sharepoint-2010-content-databases.aspx

share|improve this answer
    
Thanks Panter. I have full CA access on the CloudShare environment. I think I've figured the issue out on my own and I should have known since I went through this before on this project. My clients server team has been applying updates to the environments without notifying me of the changes. The first was applying the June 2011 CU back in August. Since we had already been through this once I didn't think we needed to review this again but it apparently they install Office Web Apps which is causing my CloudShare environment heartache since I don't have that installed. Testing tonight.... –  Scott Rooke Oct 13 '11 at 3:24
    
Good luck Scott. –  Panter Oct 13 '11 at 17:06
1  
Here's another update. Unfortunately, after reviewing both servers and getting each to the same SP and CU level, I'm still having NO FUN with my SharePoint servers. I've reviewed the Log file and there isn't anymore details. –  Scott Rooke Oct 18 '11 at 1:20
    
Here's another update. Unfortunately, after reviewing both servers and getting each to the same SP and CU level, I'm still having NO FUN with my SharePoint servers. I've reviewed the Log file and there isn't anymore details. Does anyone have any ideas of what else I can do to diagnose why the restore process does kickoff but then fails towards the end. I've tried looking at SQL Profiler and looking through SP logs. Thanks! Scott –  Scott Rooke Oct 21 '11 at 15:25

"To restore a site collection, user must be site collection administrator." to quote "Matt" from http://social.msdn.microsoft.com/Forums/sharepoint/en-US/6b728bb4-cb77-4db0-a907-0544eef6cdc6/why-is-spsitecollectionrestore-thrrowing-access-denied-errors-even-when-run-with-elevated

I was trying to restore using Administrator login. So I added user Administrator as a site collection admin. (site settings > Site collection administrators) of the source site.

After I did the backup again on the source site I was able to restore sucessfully to the new location.

share|improve this answer

PS C:\Users\Administrator> restore-spsite -identity sp2010/apps/procedures/sites/pps -path C:\temp\20111010091_spdd-dev08.bak -force

  • I suggest to change the location .bck file from C drive another drive or another server.
  • Check the folder and provide read / write permissions
  • C:\temp\ replace C and use server ip 192.168.*.\temp\20111010091_spdd-dev08.bak
share|improve this answer

Another option that I have found for restoring a site collection to a different domain to the source domain (and where the source site collection cannot be set up with the site collection admin for the destination domain) is to grant the user account doing the restore access to the web application.

$w = get-spwebapplication http://[urltodestinationwebapp]
$w.GrantAccessToProcessIdentity("[destdomain\restoreaccount]")

Now, this will probably only work if you are also restoring to a clean content DB. What I mean is that if you have attempted to restore and received the access denied error, then you will need to create a new content db to run the restore successfully.

Ref: http://www.brightworksupport.com/access-denied-when-restoring-site-collection/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.