Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Here are the steps I am taking

  1. Updating the existing MDS to enable hub (setting URI to a specific site collection)
  2. Update the content type in the site collection to be set to publish
  3. Run the timer jobs (content hub and the subscriberjobs)

Not seeing the content type, and on the content type it has no last publish date listed.

Ideas as to why?

share|improve this question
    
nothing in the error log –  dbobrowski Oct 6 '11 at 13:29
    
It may be early, but what is MDS? –  Tim Gabrhel Oct 6 '11 at 13:33
    
When publishing, errors do not go in the SharePoint error logs, they go to /Lists/ContentTypeSyncLog/. You can access it by Site Settings > Site Collection Admin > Content Type Publishing > Content Type publishing error log. is anything in there? –  Tim Gabrhel Oct 6 '11 at 13:35
    
@Tim MDS = metadata service I wasn't looking in the ULS logs, I meant there was nothing in the content type sync error list. –  dbobrowski Oct 6 '11 at 13:42
    
Also... on "content type publishing" the correct metadata proxy is shown –  dbobrowski Oct 6 '11 at 13:44
show 2 more comments

3 Answers 3

I had the issue where some site collections would receive the content types, while others would not. This is what finally solved my problem:

  • Central Admin/Application Management/Configure Service Application Associations
  • Select the appropriate Application Proxy Group
  • Uncheck the MMS thats having issues and click OK
  • Wait a couple of minutes
  • Select the Application Proxy Group and add the MMS back
  • Either wait for the Content Type Hub job to run, or go to Central Admin/Monitoring/Review Job Definitions, select Content Type Hub, and select 'Run Now'
  • Either wait for the Content Type Subscriber job to run for your Web App, or 'Run Now'

This worked for me. I never had any errors in any logs. This was a very frustrating issue.

share|improve this answer
add comment
up vote 0 down vote accepted

I fixed my issue by creating a new site collection to serve as the content type hub, then changing the metadata service to point to that new site collection for the hub property

http://www.sharepointanalysthq.com/2010/11/how-to-change-the-content-type-hub-url/

I believe my original issue was due to me not waiting for the "content type hub" timer job to complete before running the "content type subscriber" job. In addition, for anyone running into this issue, be sure you go to the site collection serving as the hub and in the site content type >> specific content type >> properties, click publish BEFORE the jobs run.

share|improve this answer
add comment

I've struggling for the last day trying to get this to work. I'd done everything that was required by every guide that I had read.

I was afraid that it might be something to do with the order of the way I had put it all together. I had already started using the content types and didn't want to have to recreate them and reassign the data.

Out of curiousity, and chance, I created a new content type that used one of my desired types as its parent. After running the timer jobs, lo and behold, both types were available in the new site collection.

I was then able to "unpublish" this content type and delete it. The desired contetnt type remained put. Sweet relief.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.