Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am getting issues while migrating SP2007 - SP2010. Below are the steps I have followed as part of SharePoint data migration:

  1. I used two different systems and installed MSSQL 2005 & SharePoint 2007 in one system(timpa04-vm16838) and in another system I installed MSSQL 2008 & SharePoint 2010 (timpa04-vm18133).
  2. In First System (timpa04-vm16838) after installing SharePoint 2007, I have installed Old SharePoint connector(SPConnsetup.exe) and made data setup on different sites collections with CPS and Non CPS sites.
  3. In MSSQL 2005 server, identified & took the backup of the database where my data setup was created. (dbo.WSS_Content)
  4. In another system (timpa04-vm18133), After installing SharePoint 2010, installed SharePoint 2010 connector & made data setup on different site collections with both CPS and Non CPS sites to make sure connector is working.
  5. As Process of data migration from SharePoint 2007 to SharePoint 2010, In MSSQL 2008 I have created a new database with name “WSS_Content_2007” and restored the backup database (which was created in Step 3).
  6. Now I have mounted the dbo.WSS_Content_2010 to the SharePoint 2010 Web application using following command in SharePoint 2010 management shell Command: PS C:\Users\Administrator> Mount-SPContentDatabase -Name WSS_Content_2007 -WebApplication http://timpa04-vm18133:44508 –Verbose
  7. Once the Database is completely mounted to the Web Application, navigated to SharePoint 2010 ‘Central Admin -> Application Management -> ‘View all site collections’.
  8. Make sure that Database name of mounted Web Application’s site collection is “WSS_Content_2007”.
  9. Navigate to the ‘Site Collection URL’ (Ex: http://timpa04-vm18133:24108/sites/ca)
  10. When navigated to above site collection URL, If the Site collection Template: a. Is Non-CPS site Result is “Web Part Error: A Web Part or Web Form Control on this Page cannot be displayed or imported. The type could not be found or it is not registered as safe”. b. Is CPS Site Result is “Error: Access Denied”

• After completing the migration process, I have created a new Web Application & new Site collection and navigated to “CA Clarity PPM Binding” of CPS Site encountered with following Error: “Web Part Error: A Web Part or Web Form Control on this Page cannot be displayed or imported”. • SharePoint 2010 installation is an “Stand alone” installation, because I am not able to connect MSSQL server 2008 with SharePoint 2010 if the installation type is “Server Farm”.

share|improve this question
add comment

migrated from stackoverflow.com Oct 6 '11 at 9:15

This question came from our site for professional and enthusiast programmers.

2 Answers

Can you hit up the web part system page eg: 'http://timpa04-vm18133:24108/sites/ca?contents=1' see if you can access it. Also the description confuses me slightly you mention 'http://timpa04-vm18133:44508' is the web app where you have mounted the content db to yet your accessing this site collection on another port? Also whats the deal with the off numbered ports?

I would also suggest that your alternate access mappings need to be created if you have not done that step.

share|improve this answer
add comment

Have you run Test-SPContentDatabase against your content databases? It sounds like you have references to features and/or web parts in your 2007 environment that haven't been installed in your 2010 environment.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.