Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

After installation of SP1 for SP2010, the items in libraries no longer displayed in a dialog. On the list is indicated that the items should be displayed in a dialog. After research I found out when a new view is created on the list the items reappear in a dialogue open when the new view is used.

The problem only appears when i use de Edit (link to edit item) column. When using the ribbon all works fine.

Does anyone have a clue why this happens and how to solve this?

A solution I came up was to use PowerShell to clone alle views and delete the original views, but someone might know a cleaner/better way

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The problem are the AJAX options of de List View WebPart. By disabling these options the action will work again. This bug is already sent to microsoft.

How can it be reproduced? - Create a new site collection. - Add a new document library to the site collection. Make sure the library opens its screens in dialog mode using advanced settings. - Change the default view, add the edit button in the view. - Change the list view webpart setting to enable the Enable Asynchronous Update and Show Manual Refresh Button in the AJAX options sections. - Upload a document and fill out the missing metadata. - Edit the document using the edit button on row level. Please note - Make your changes and press save. - The document will now open in full screen after pressing save.

What are the workarounds found? - When the library is set to open in full screen mode instead of the dialog, the issue is not happening. - Only use chevron and ribbon, when editing a document. - Disable AJAX options.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.