Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Our web developer helped me customize our SharePoint 2010 web application (few images and colors). Very basic. He made changes to the master page and I selected that master page and applied it to all sub-sites. Looks great - for me. Not for any other user. No one else can see the customizations. What are we missing? Thanks!

share|improve this question
add comment

4 Answers 4

up vote 19 down vote accepted

Did you remember to check in the master page?

Site Actions > Site Settings > Galleries > Master pages and page layouts

Find your master page, select it and select Publish then Approve

share|improve this answer
    
hmm - All of the files listed in Master pages and page layouts are greyed out and I can't select anything. –  user4747 Sep 30 '11 at 18:49
2  
Can you get the developer to help you publish the pages? If you used SharePoint Designer for editing you can also use this to check it in –  Anders Rask Sep 30 '11 at 20:07
2  
Also make sure any CSS files that are placed anywhere are checked in, too. –  James Love Sep 30 '11 at 22:04
    
None of our docs appear to be checked out according to the 'checked out to' column in "Master Pages & Page Layouts". Should they be showing 'checked out' on this page if they are? Some background in case it's helpful - Our developer did the work on a test site, then sat with me & showed me how to apply these changes to our prod site as he doesn't have access. We editted v4.master by adding a link to customstyles.css & also added a few images. Did this using SharePoint Designer. Then I selected v4.master from Site Master Page Settings and checked 'Apply to subsites'. Thanks in advance! –  user4747 Oct 3 '11 at 17:13
1  
check that Page Layouts and master pages has Approved in approval status (site > site actions > site settings > galleries > master page) also check your Style Library for checked out files ( site actions > manage content and structure > style library ). You can also do this from SharePoint Designer by selecting the site > master pages / page layouts) and check if files are not checked in –  Anders Rask Oct 7 '11 at 20:55
add comment

don't forget to publish your master/layout and site pages.

A common mistake that I have made a thousand times.

share|improve this answer
    
I think I figured out part of my confusion... When I right click on the modified master page to check in/publish, I don't get the window that I think I should be getting... No option to publish. Just a window with "Files: custom.master", "Comments on version:" box and a check box for "Keep files checked out". It doesn't look like one I've seen in books/internet which also includes "What type of version do you want to check in?" –  user4747 Oct 7 '11 at 12:09
    
Does anyone know why? –  user4747 Oct 7 '11 at 12:48
    
BTW - everything is enabled under SharePoint Designer Settings for the Web App. –  user4747 Oct 7 '11 at 15:10
add comment

We never did figure out why the items are greyed out or why the check-in box didn't have the option to 'publish', however, we did discover that the CSS we added wasn't published. Once we published it (and corrected the path to the images), it was viewable by all users. Thanks to everyone for your help!

share|improve this answer
add comment

Answers above helped me to solve similar problem, but I needed to add one more step. I'd try those steps next time:

  • check if all the styles are checked in and published
  • check if the user who can't see styles has permission to access style library
  • check if the user who can't see styles has permission to access modified master page
  • check out and check in modified master page from designer (this was necessary for me, but I'm not sure why)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.