Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have Sharepoint 2010 and MS Word 2007.

I have the three default workflows (Collect Feedback, Approval, Collect Signatures) associated with a content type based on the document content type.

When I want to start a workflow, Sharepoint says there are no workflows available to start on this item.

share|improve this question
    
Can you verify that your workflows are added to specific content type? See this –  Vedran Rasol Sep 28 '11 at 12:00
    
Yes, I have. Does a workflow have to be associated with both the library and the content type, or is an association with the content type enough? –  systemovich Sep 28 '11 at 12:45
1  
Association with the content type is enough. Are you sure your item content type is the same as one you associated workflow with? I did quick test and I don't see any possible issues so there is most likely some simple mistake here. –  Vedran Rasol Sep 28 '11 at 12:51
    
@Vedran, It is associated with the same content type, because if I make changes to the template attached to the content type, those changes appear in new documents based on that content type. Those new documents then still do not have any workflows available. –  systemovich Sep 28 '11 at 14:19
add comment

2 Answers

check this , it may help, It's not the same but could give you an idea. http://spreza.blogspot.com.au/2013/05/reusable-workflow-which-is-associated.html

share|improve this answer
1  
So not really an answer, then, just a link to your blog ;-). Seriously, you should only use Answer for actual answers to the question, and we require disclosure of any affiliation with products or websites. Please see May I promote products or websites I am affiliated with here? for guidelines. –  SPDoctor May 23 '13 at 18:29
add comment
up vote 1 down vote accepted

The reason was that the three default workflows were disallowed on the Remove Workflows page. I merely allowed them again. Everything is fine now.

You get to the Remove Workflows page by going to the relevant document library, clicking Workflow Settings, selecting the applicable content type and then clicking the "Remove a workflow link".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.