Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have an content type in my feature, and sudenly when I tried to debug my feature, i got the following error:

Error occurred in deployment step 'Activate Features': 
The content type with Id 0x01005B614C2D37A841DE8D1739C2A6ECDF82 defined in feature {bla bla} was found in the current site collection or in a subsite.

The thing is that even if I manually retract and delete solution and try to redeploy, error is still present. I can't find my content type in gallery, nor activate feature containing it by hand from feature gallery. I found it in content database by hand (through SQL Server Studio), but I'm far from deleting it by hand from database because I don't want to mess up whole site collection and web application. What can be the cause and how do I eventually can get rid of that error?

I found one post on MSDN which suggested site collection deletion, but I'd like to avoid that.

share|improve this question
    
Running 'iisreset' before feature activation also works. Not very efficient maybe, but for development it works ok. –  jjczopek Sep 30 '11 at 12:43
add comment

4 Answers

up vote 1 down vote accepted

This is a bug that comes up every now and then. Sometimes it will clean itself up when you redeploy. Try that before deleting the site collection.

share|improve this answer
    
Today everything works fine... –  jjczopek Sep 27 '11 at 9:14
    
Anita's answer was most correct. It is the restarting of VS that clears things out. –  Mike Oryszak Sep 27 '11 at 12:08
add comment

Try restarting Visual Studio. Sometimes it locks some stuff, I've seen it before.

share|improve this answer
add comment

I faced this issue before but did you to iterate through the Site Collection/Webs via PowerShell to see if something is missing?

Also, check the ULS log to find more specific information. Did you try setting the OVERWRITE attribute to TRUE because it overwrites the existing Content Type if any. If you don't find anything, (as Mike suggested) you may have to delete the Site Collection and recreate it.

share|improve this answer
    
yes, I did iterate through site content types with powershell script, and I couldn't find my content type. I think I tried also OVERWRITE=True, but it didn't work. Will try it again thou. –  jjczopek Sep 26 '11 at 22:58
add comment

The issue comes every now and then.. in the case try to retract the code with visual studio. rebuild it and again deploy. Or may be you can put activation status to "No Activation" and then deploy your solution.

Hope it works...

-- regards,

Deepak

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.