Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am doing a Farm installation of SP 2010 in a VirtualBox instance for the purpose of local development. I am using Server 2008 R2, SQL Server 2008 R2. Since the instance of SQL server is local and not remote, there is common workaround that involves creating the database using New-SPConfigurationDatabase.

However, this approach is failing, as you see in the screen shot below. What is odd is that I never get prompted for the database instance or database name. Once I het enter in the script, I get a credential prmpt into which I enter the SQL credentials for the user in this format:

u: SERVERNAME\username
p: userspassword

I enter a new passphrase, which I understand is the farm Administrative passphase to be used later. I surmise that this is the case since it is the Configuration Wizard that we are stepping out of here.

The local user account that I am using when running the PowerShell script has access to the database server and has the following roles: public, db creator and securityadmin. AD is not installed on the server. I have fully tested my SQL Server installation and it is operating properly.

enter image description here

share|improve this question
    
How are you specifying the user account? Is it fully qualified? I use the approach I supplied below to create standalone single-box installs all the time and it has always worked for me (though I always have a domain controller configured on the box). –  webdes03 Sep 28 '11 at 16:13
add comment

2 Answers 2

up vote 2 down vote accepted

When you call your New-SPConfigurationDatabase cmdlet, the FarmCredentials parameter should be a PsCredential object, and the farm passphrase should be a securestring, so it should look something like the following:

$passphrase = (ConvertTo-SecureString "FarmPassphrase" -AsPlainText -force)
$credentials = New-Object System.Management.Automation.PsCredential "domain\username", "password"

New-SPConfigurationDatabase -DatabaseName "Config_DB_Name" -DatabaseServer "dbserver.corp.local" -AdministrationContentDatabase "Admin_DB_Name" -Passphrase $passphrase -FarmCredentials $credentials

This also assumes that your user specified as the farm credential has the applicable SQL access, as Mike pointed out.

share|improve this answer
    
Make sure your accounts have proper permission in Windows and SQL Server. Make sure you use the domain name when entering your Farm account credentials. Make you your passphrase is conforming. Also, if you are using a VM, snapshot first! –  mmcglynn Sep 28 '11 at 18:03
add comment

Can you make double sure that the account you are using when running the PowerShell script has access to the database server and is in the db creator role?

Having the db server local versus remote is never an issue, are you using local user accounts (non AD)?

share|improve this answer
    
question updated with specifics related to your answer. –  mmcglynn Sep 26 '11 at 20:20
    
The PassPhrase is not the user's password. Tt is used to secure farm communications. –  mmcglynn Sep 28 '11 at 19:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.