Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On my site for some reason the left navigation doesn't always show up on every page - even though they use the same master page. I've searched Google and through all of the site settings trying to figure out why this is, but I've had no joy :(

Here's the HTML for the area: http://pastebin.com/1UXpPrsT

Yet on other pages this is populated just fine. Any suggestions would be very welcome.

Thanks!

Edit:

Okay, on the 'Page layout' it says (Welcome Page) Summary Links with absolutely no way to select the page I created that the other pages use... that's the problem here - if it's set to welcome page, it has no left navigation, but on some pages it's the only option I have! :/

share|improve this question
    
So many awesome answers, thank you guys and I wish I could vote you up since it's all worth trying, but it's almost certainly a problem with the page layout - but how do I change that? Thanks –  Nick Sep 28 '11 at 21:46
    
Nick, see my updated response below. I was able to replicate your issue and tested my solution to ensure it works. –  webdes03 Sep 28 '11 at 23:09
    
I spent around 3 hours on a saturday trying to figure out why quick launch/ tree view are not getting displayed on welcome page inspite of using v4.master. After much digging and looking at page source I realized sahrepoint was injecting style to hide it. But how do I turn it off was a million dollar question. After about an hour of googling i came across this post. THANKS A TON for saving my rest of saturday. :-) SunilGT –  user5889 Dec 3 '11 at 9:11
add comment

3 Answers 3

This happens with page libraries that are on sites without the Publishing features turned on. Turn on the publishing Site Feature and add your pages to the Pages library.

share|improve this answer
    
Thank you, but as above, how do I change this option? I cannot see it in settings anywhere unfortunately :( –  Nick Sep 27 '11 at 18:52
    
Have a look at this: beyondweblogs.com/post/… –  John Chapman Sep 27 '11 at 19:06
add comment

This can also happen on site with Publishing turned on, but a PageLayout was selected without the QuickLaunch or when custom scripting was done to suppress the QuickLaunch.

share|improve this answer
    
Thank you, but how do I change this option? I cannot see it in settings anywhere. –  Nick Sep 27 '11 at 18:51
add comment

Edit: Mike beat me to it ;-)

Certain page layouts will hide the Quick Launch. This isn't just related to publishing features, but the type of layout you're using. Certain web part pages, welcome pages, etc. will hide the quick launch. Usually they hide it with some simple CSS, so you should be able to re-enable it.

<style type="text/css">     
    /* hide quick launch */    
    #s4-leftpanel {
      display: none;
    }
    .s4-ca {
      margin-left: 0px;
    }
</style>


<style type="text/css">    
    /* show quick launch */    
    #s4-leftpanel {
      display: block;
    }
    .s4-ca {
      margin-left: 155px;
    }
</style>

UPDATE:

I ran though this in my lab to duplicate your scenario. It turns out that the Welcome Page page layout uses a more specific CSS selector, so you have to use that same selector if you're going to reverse the action and show the left panel.

If you go to a page using the welcome page and view your source (assuming you're using the OOTB master), you'll see a CSS block directly before the <link rel="shortcut icon"> tag that looks like the following. This is the markup that the welcome page layout is using to hide the left panel:

<style type="text/css">
  .v4master #s4-leftpanel { display: none; }
  .v4master .s4-ca { margin-left: 0px; }
</style>

Given that the CSS selectors are prefixed with ".v4master", you also need to use that prefix in your overwrite markup, so you would need to use the following (updated from my original solution above):

<style type="text/css">    
    .v4master #s4-leftpanel {
      display: block;
    }
    .v4master .s4-ca {
      margin-left: 155px;
    }
</style>

I have tested this, and it does work. In my test I simply added that markup to a Content Editor Web Part on the welcome page and it turned the left panel back on and everything behaves like it wasn't turned off by the page layout in the first place. Obviously you have to do it to every page that uses that layout if you really want it everywhere. The smart thing would be to create a text file that has the markup in it, upload that to your site, then point the CEWP's to that file, so you have a central place to change it in the future.

share|improve this answer
    
Sorry how do I add a comment on the things above? I've tried the CSS tweak but no joy unfortunately, I've also looked into the publishing features but cannot find anything under the 'Publish' tab - am I doing something wrong? I've also gone through the publish/approval process from the start with no joy, can't see any option for the left navigation in there. Thanks again –  xn dx Sep 27 '11 at 9:17
    
Certain page layouts automatically hide the quick launch, this isn't an option that you can just set. If the page layout you're using is hiding the left panel, your only options are to either a) add provisions to show it, or b) create a custom layout that doesn't hide it. If you do a "view source", you should see markup like my first block that is hiding the left panel; you could add a CEWP at the bottom of your page with the second block of code to "undo" the native functionality and show it instead. –  webdes03 Sep 27 '11 at 14:35
    
Many thanks, I've just searched through the source (and the source of all CSS files, according to Firebug) for #s4 and didn't find a single hit, bizarrely... I've looked in the HTML and it isn't even there, there's no sidebar :/ But yes, on the pages it does display on, it is called #s4-leftpanel - so bizarre!! –  Nick Sep 27 '11 at 18:50
    
Sorry, to add some context here's the HTML for that area: pastebin.com/1UXpPrsT –  Nick Sep 27 '11 at 19:00
    
If the left panel is being hidden by the page layout, the CSS markup gets added to the head of the page through the use of the AdditionalPageHead placeholder in the master page. You wouldn't see the CSS anywhere near where the left panel markup is on the master itself, or in the linked CSS files, it is written to the head of the page dynamically by the page layout. If you're using the standard V4 master, it would be right before the link tag that populates the favicon. –  webdes03 Sep 27 '11 at 19:40
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.