SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I developed and deployed a custom web service to "layouts" folder.

I can call it without problems from a .net application with NTLM validation.

But I need call it from a java application with "JAX-WS". So I require anonymous access to WSDL of the custom web service.

How can i allow anonymous access to the WSDL?

share|improve this question
up vote 6 down vote accepted

Why are you deploying your Custom Web Service to the layouts folder at first place?

You need to copy the Web service files to the _vti_bin virtual directory

Copy the Service1wsdl.aspx file, the Service1disco.aspx file, and the Service1.asmx file to the _vti_bin virtual directory. This is the directory where all default Web services are stored.

Copy the corresponding assembly (.dll) file to the _vti_bin/bin virtual directory. Note The _vti_bin/bin virtual directory is mapped to the \Server_Name\Program Files\Common Files\Microsoft Shared\Web Server Extensions\ISAPI directory.

Next, you must include the service in the list of default Windows SharePoint Services Web services that is displayed in the Add Web Reference browser of Visual Studio .NET. Follow the complete tutorial here

For setting the anonymous access to the Web service: Go to IIS -> Select the Web site -> Go to _vti_bin folder -> Select the custom web service -> Right click and enable the anonymous access.

Update: Just adding a very helpful tool for developing the custom web service

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.