Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've deleted a group from a site; now when I try to create the group of the same name, it throws this error:

Error 
The specified name is already in use.

Please try again with a new name. 

Troubleshoot issues with Microsoft SharePoint Foundation. 

Correlation ID: 5bf5db27-b32d-468d-b417-e255416d1981 

Date and Time: 9/21/2011 2:33:14 PM 

The group isn't in the site's Recycle Bin. Is there another recycle bin somewhere that stores these items? Thanks.

share|improve this question
    
Did you delete one of the standard groups (Contributor, Designer etc) or was it a custom made group? –  Daniel Ziga Sep 21 '11 at 12:17
    
Thanks, Ziga, for your reply. This was a custom group: "Health Services - Page Editors". –  Alex C Sep 21 '11 at 12:30
1  
Have you made sure to delete this group from the Site Collection and not just the site? –  Daniel Ziga Sep 21 '11 at 12:43
    
It turned out the item was in one of the many recycle bins that SP2010 has. Once it was deleted from there, all was fine. –  Alex C Dec 2 '11 at 17:16

3 Answers 3

up vote 1 down vote accepted

As far as I know no one other than a Site Collection Admin can delete a SP Group. Make sure that group is deleted by a SC admin.

On the other hand, if you look at the privileges associated with Full Control permission level (...or any permission level for that matter), you'll notice that there is no permission for Delete Group, so this permission cannot be granted explicity.

share|improve this answer
    
That helped me in finding the group, how do I restore the group now? –  user23532 Feb 8 at 0:25

Cause: There is different way to delete permission group, mistakenly I have deleted the group from "Permission Tool->Remove user permissions" which shows permission group deleted but it still doesn't allow creating a new group with the same name

Cause/Solution-> Deleting group from "permission Tool-> remove user permissions" doesn't delete the group if you have taken above approach then go to following location and delete all the earlier groups and try to create once again

Url: http:///_layouts/groups.aspx

Or follow following navigation: Site Settings -> (Users and Permissions) -> People and groups -> Click on "Groups" from left navigation

ideal way to delete group permanently from site collection-> "Click on Permission group-> Setting-> Group setting -> Delete"

share|improve this answer

Got the Same issue. I deleted a sharepoint Security group in my site collection and tried to Create a Sharepoint group with same name. I got the error that 'You can't delete the group because it is already exists'.

I was logged-in to SharePoint designer in the security groups Removed the current group what i need to create. Thus the group deleted and i was able to create new group with the same name in that.

finally the solution is remove the group from designer and try to recreate the group.

Regards, Suresh Pydi

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.