Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I installed Polish language pack for Sharepoint, but unfortunately blog sites are not supported. Is there any way to provide translations for particular site collection templates, which are not supported in other than English language?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You can always copy original resx file and rename it to your language specific (in your case something.pl-PL.resx). Then you can translate it manually.

Two main resx files are:

  • Core.resx - located in x:\Program Files\Common Files\Microsoft Shared\Web Server Extensions[SP version]\Resources
  • wss.resx - located in virtual directory with default location X:\Inetpub\wwwroot\wss\VirtualDirectories\\App_GlobalResources\ (Note: Iis reset is required)

I think 99% of all needed translations are there but you can also check other resx files at those two locations.

You can find some additional info on this topic at:

Edited:

Keep in mind since you installed Polish language pack you already have localized resx files.

Edited 2:

Title of this article is self explanatory: SharePoint 2010 Meeting Workspaces and Blogs are not MUI enabled.

So only 'solution' is in comment posted by @AndersRask (with all disadvantages):

share|improve this answer
    
Your answer was somewhat helpful - I found out, that core polish resource file contains localized blog strings. So I created new site with polish language, but when I try to select English as alternative language, I get this error: This site is based on a site template that does not support alternate languages. Any workarounds? –  jjczopek Sep 19 '11 at 17:12
1  
I guess that if you translate the relevamt words in the existing core.resx by overwriting the english words, they would show up. This ofcourse has alot of drawbacks as you risk getting polish translations in your US sites, and risk that changes is overwritten when adding hotfixes, and service packs... –  Anders Rask Sep 19 '11 at 17:27
add comment

This is not best practice, but sometimes SharePoint forces to do this. We found solution, how to enable additional language for webs based on blog template. It is enough to change couple of values in the content database. It works in many our projects, bugs depended to this solution not found. More detail description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.