Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a web page in sharepoint 2010 on which I have added a document library using a XSLT ListView web part in sharepoint designer. I created a parameter that gets its value from the URL and is used to filter the list of documents.

I then want to group the documents by a category field, however when I do this the groups show in the page with the correct number of filtered documents showing in the group header, but when I expand the group nothing shows up.

If I remove the filter the groups work fine, expanding and showing all the documents. But as soon as I filter it using my parameter the documents will not show when expanding the group.

The filter works by itself & the grouping works by itself but not together.

Any ideas why and how to fix?

share|improve this question
    
HiJohn, Can you please explain how you to created xslt list view web part and filtering with a parameter value from url in SharePoint designer 2010. Thanks, Raghav –  user17637 Jun 15 '13 at 10:19
add comment

2 Answers

This link should help you out.

When you sort data in a Data View, you modify the order in which the data appears so that it’s easier for you and your site visitors to understand the data. Examples of sort order include alphabetical and numerical ordering. You can create additional sort orders using the Advanced Sort dialog box in SharePoint Designer 2010.

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Stuart Pegg Aug 21 '12 at 9:47
1  
@StuartPegg Agree! I added link in Oct 2011 and dint know the rules –  saumilm Aug 21 '12 at 10:30
add comment

When you expand the group, the listview webpart does callback(and not postback) to retrieve the data. While callback, the value of url parameter is not passed (unless you set a default value) and so you don't see data.

To make it work :

1) Right click webpart 2) Go to webpart properties 3) Under "Ajax Options", Check "Enable Asynchronous update" 4) Click Ok and Save page

Open the page in new browser,It will work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.