Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Suddenly, when we attempt to redeploy a solution from central admin > Operations > solutions.. it says Error with no option to redeploy or remove.

Also noticed, in Timer Job Status Application Server Administration Service timer jobs for the two WFEs show up as Failed.

The WFE servers are up and web services on each appear to be fine.

Not sure if related ...

I'm looking at the SharePoint logs on the moss sever and can't seem to find anything during the solution deploymment steps. (#2: Cannot open "Resources.en-US.resx": no such file or folder.)

Am also seeing:

The Execute method of job definition Microsoft.SharePoint.Search.Administration.SPSearchJobDefinition (ID 0baf4ec6-b0d3-488b-8f04-bb7e15cc2ac1) threw an exception. More information is included below. Could not access the Search service configuration database

Looking on logs on one WFEs.. I don't seem much either.. do see errors like:

I only see entries like this:

High Configuring the Search Application web service Url to 'https://xxxx:56738/SharedServices3/Search/SearchAdmin.asmx'. No critical entries.

Some wild guesses.. - at some point since our last deployment, we created sites at the root of the WFE hostname that are not SharePoint sites through IIS. Might MOSS be trying to deploy there? - Recently we deployed some custom DLLs to a few sites only on the WFE. We did not deploy these to the MOSS server. Does that cause a problem?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Could you please try to run these commands as a bat file everytime you plan to re-deploy your solution and get back to again if it doesn't workout? Note: I assume your Custom timer job might be deployed using Web application level Feature

stsadm -o upgradesolution -immediate -allowGacDeployment -name blah.wsp -filename blah.wsp

stsadm -o execadmsvcjobs

iisreset /noforce

stsadm -o deactivatefeature -id C2EC140A-FF1B-4828-8238-1E37704E53A4 -url http://WebApp/ -force

stsadm -o activatefeature -id C2EC140A-FF1B-4828-8238-1E37704E53A4 -url http://WebApp/ -force


net stop "Windows SharePoint Services Timer"

net start "Windows SharePoint Services Timer"

@echo Finished...
@pause

Also, what does the WSP contains, a custom timer job etc? Please elaborate more

share|improve this answer
    
What if I don't know where the WSP file is? Also, In Central Admin I'm not getting an option to remove or redeploy. Maybe I need to flush all my timer jobs? –  cyberpine Sep 16 '11 at 14:17
    
If your WSP contains a custom timer job then it is important to run the commands (i have updated in code above) every time you re-deploy the WSP package. You can see the list of all solutions deployed on Farm using Central Admin -> Operations -> Solution Management. I would recommend you to extract the solution using archive.msdn.microsoft.com/SPSolutionExtractor and see what solution contains and re-deploy it using the above commands –  Falak Mahmood Sep 16 '11 at 15:27
add comment

1) Once a solution deployment fails, you have to cancel the deployment before you can take further action on the deployment.

stsadm -o enumdeployments

stsadm -o canceldeployment -id [GUID listed in enumdeployments]

2) Once you do that, you may get some details on the status of your deployments from Central Admin.

3) For example, you may get an error indicating the "Windows SharePoint Services Administration" Service could not be contacted on one of the Web Front Ends (WFE). In this case, it is either a permission issue or the WSS admin service is not running on the server mentioned. Make sure it is running. If it is running on both the central admin server and front end servers, then it could be a permissions issue. You can try making sure that the farm account (account used by the Windows SharePoint Services Timer) is in the local Administrators group on the front end servers. See if that helps. Though I have read conflicting guidance on whether the farm account requires local admin, you can at least temporarily add it to local admin for troubleshooting.

4) After setting the permissions and verifying the WSS service was running, I started getting an immediate error without any details. However, after I canceled the deployment, central admin solution management listed all the servers that it managed to deploy to. Consistently, one of the front-end servers did not show up in the list of deployed servers.

5) I logged into that server, ran Products and Technology wizard on that WFE server to sync it up, and then ran the solution deployment command from that server. Then it started working for me.

So the problem could be a misconfigured WFE that is not responding to solution deployment. You should also make sure that you don't have any offline servers in your farm from the Central Admin -> Operations -> Servers in Farm page.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.