Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When opening an Office document the splashscreen gets stuck for about 30 seconds with the message "Contacting the server for information". How can I get more information about which information it is getting and from which server?

The answer given below does not work for me.

share|improve this question
    
This is an exact dupe of the question you linked to, which normally would be closed. However as the OP of that question no longer has an account and your question has better wording, I've merged it into this one. –  Alex Angas Sep 18 '11 at 1:33
    
FWIW I experience the same issue but haven't had time to look into it. –  Alex Angas Sep 18 '11 at 1:33
add comment

5 Answers

The initial problem is just because of antivirus installed on server as well as client machine. Add website address and file extention types in the exception list.

share|improve this answer
add comment

In my experience I have found a few things cause the slow down and login behaviors raised by the original question.

Slow downs - may be caused by potentially performance configurations by the SharePoint admin (for ways to get the server changes made ref: Fine Tuning Your SharePoint 2010 Environment – Front End Optimizations) ; or by having lists with membership changes where the list no longer has (or percieves to have) valid users referenced by the list items (people or group pickers); or if you have a bad list ( or corrupt one) and the SharePoint reference is getting lost becuase it can't find home.

Login issues associated with Slow Downs - may be caused by one of two network configurations. The first is manageable by the end-user and that has to do with setting or confirming you have the proper trust relationship for your Browser to communicate with SharePoint.

Under the IE (presuming this is the dominant default browser) Select -> Tools -> Internet Options -> Security -> Local intranet -> Sites -> Advanced and make sure your SharePoint domain is in the list of approved sites. You can use a wildcard such as the following *.yoursharepointsite.com like *.ibm.com if your sharepoint site is structured like sharepoint.ibm.com. This will tell IE to pass your credentials properly to the site because it "TRUSTS" it.

The other solution for login related Slow Downs can be provided by your Network team and insuring that as a user and a local domain you can trust reach the site withing your network (DNS ROUTING and DEFAULT CONFIGURATION do not have this set up).

The question with any solution is whether it addresses the initial problem.. without crystal clear example of what the problem is we're all just shooting at a percieved target with what we hope is useful.

share|improve this answer
    
I agree that this is probably a network configuration problem because we noticed the same problem when opening an Office document directly from internet (using http protocol). Now we opened a ticket to Microsoft in early October and we still haven't received a valid answer. In order to address the problem we need to know what they are doing when they are "Contacting the server for information". I'll add an answer when Microsoft finally answer our ticket. –  rold2007 Feb 15 '12 at 5:51
add comment

If you run a tool like Fiddler http://www.fiddler2.com/ you may be able to see when the request actually starts and ends. It might also be a good idea to try it with word or excel already open so that it takes the client initialization out of the mix.

The next thing I would check is the Anti-Virus software running on the server. In many cases every file uploaded or downloaded has to be checked by the Anti Virus scanner. I've seen some things over the years where maybe a traditional server based antivirus tool like Norton or MacAfee take significantly longer than expected.

share|improve this answer
    
For now I am not allowed to install any software on the machine I work on so I can't try Fiddler yet. I should be able to try it in a week or so. The problem only happens when opening Word/Excel the first time. If I only open a local document first there is still the 30 second wait. Symantec is installed on the client machine and on the server. I agree that anti-viruses can be a PITA, but there's no reason it could slow down only the first opened document. I'll keep you in touch when I will have tested Fiddler. –  rold2007 Sep 19 '11 at 0:05
    
In your comment you said if you open a local document, there is still a 30 second delay. It sounds like there is something slowing down the local system or office client. I would start there. –  Mike Oryszak Sep 19 '11 at 0:25
    
Sorry, my statement was not clear. Opening a local document is almost instantaneous. When opening an Office document stored on SP after opening a local document I still get a 30 seconds delay. I have also reproduced this problem on many (all my client's machine I could test) different machines. I'm looking forward to test it with my laptop to be able to try different configurations and diagnostic software (Fiddler) as I don't have admin rights to do it on my client's machines... –  rold2007 Sep 19 '11 at 3:27
add comment

We experienced the same thing. I do not understand why this works in our environment, but it does.

Open IE, go to "Tools > Internet Options > Connections > Lan Settings" and uncheck "Auto Detect Proxy".

share|improve this answer
    
This resolved some issues for us too. –  PirateEric Feb 4 '11 at 13:31
    
Hi Kevin, works - thanks! :) Ravie –  user1667 Feb 7 '11 at 6:15
    
Sweet. I'm thrilled to hear it. –  Kevin Feb 7 '11 at 13:35
    
I've experienced the same issue / resolution with WebDAV (Explorer View) as well with no clue why it works. Some computers need this setting switched, others don't. It's weird. –  ToddersLegrande Feb 14 '12 at 17:51
    
This helped me too. Thanks. –  lwbecker2 Jul 11 '13 at 16:10
add comment

Does this happen with all clients or with just one?

I have seen this, and oddly, a BIOS update to the client's PC fixed it.

share|improve this answer
    
Hello James, almost all. Even with new computers/notebooks. Ravie. –  user1667 Feb 4 '11 at 11:04
    
I should also add the longest time is the first time - when I close the doc afterwards and open another one then, its faster. Some sort of cache (performance issue) or security validation (security issue)...? –  user1667 Feb 4 '11 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.