Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In SharePoint Server 2010, when I create a new "Blank Site" site collection, I don't have the Information Management Policy Settings link on the Document content type setting page. The only way I can make the link appear is to enable the Library and Folder Based Retention feature.

If I create a site based on the Team Site site definition, the link is there by default (without the feature activated).

Is this a normal behavior? A bug? How can I have the Information Management Policy Settings link in a Blank site without activating the Library and Folder Based Retention feature?

share|improve this question
    
Welcome to SharePoint Stack Exchange! Please tag by feature or topic and not by version or product. This helps to attract more attention to your question and keep it relevant. See How do I use tags for general guidelines. –  Alex Angas Sep 18 '11 at 1:27
add comment

3 Answers

The "Blank Site" has a lot of normal things stripped out of the site definition. There are some scenarios where it may not be a good idea to create sites using the Blank site template. I've moved away from it for similar reasons.

share|improve this answer
add comment

Its the normal behaviour of SharePoint and its not a bug. The Blank Site template just has the minimum features or libraries to start with. If you need the Blank Site with the information management policy feature on, or any other customization, then it would go for creating a custom site definition.

share|improve this answer
add comment

I know that for some reason you don't want to activate features to enable the link to appear--I honestly think you are just making your life WAY more complicated than it needs to be. But anyhow, for anyone else out there who stumbles on this thread because they are wondering why the link is not there in their blank site, you can make it appear by activating In Place Records Management in Site Collection Features.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.