Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm trying to test the anonymous version of my SharePoint portal, but every time I log-out and close the browser, when I reopen the browser, I'm logged back into the portal (automatically).

How do I prevent this behavior? I want to be able to see the portal in ie without being automatically logged in.

share|improve this question
add comment

6 Answers

Internet Options -> Security Tab -> Local Intranet -> Custom Level -> Scroll to the bottom.

User Authentication section set Logon option to Anonymous

Also with the Intranet section highlighted, you can deselect Automatically detect intranet network and remove any instances of your Sharepoint URL from the Advanced menu in the Sites area. This might not be able to be done depending on your group policies. You might need to do it from a machine off the domain and or from home.

share|improve this answer
    
This change would affect all sites; I need it only for this 1 site. Is there a way to prompt for login on a site by site basis? –  user2903 Sep 13 '11 at 14:54
    
You should be able to refine that by altering the sites in the Advanced menu. Another alternative is to fire up XP mode if you're on Windows 7 and to utilize that virtual machine to access the site, then you can configure that browser how ever you need to for testing. –  PirateEric Sep 13 '11 at 15:06
    
the solution has to work for the end users as well (100+). So there won't be any xp mode for them. –  user2903 Sep 13 '11 at 15:21
    
Why would you want end users who have permission to the site to log in as an anon user? That doesn't make a lot of sense to me. I guess I'm struggling wit the business requirement. –  PirateEric Sep 13 '11 at 16:51
2  
If that's the case, you're probably going to have to split that subsite out into it's own web application so that in IIS you can disable integrated authentication at the web app level. As a work around you might want to consider using a survey that hides usernams and allows multiple responses in the blog site. You can create look up columns to the post titles so you can get a reference to what people are commenting on. –  PirateEric Sep 13 '11 at 17:52
show 1 more comment
up vote 2 down vote accepted

So just about all the answers are correct, but I thought it prudent to include one more. Sometimes when you're working on the site's style you can end up having unpublished content being referenced on the master page or other pages of the site. This unpublished content although present, generally requires administrator rights to be viewed. It seems that once IE encounters such items on the page, it logs in to ensure that the content can be viewed. This is what happened my particular case; there were unpublished items in the style of the site, that kept causing IE to authenticate.

share|improve this answer
add comment

Disable integrated authentication. Go to Internet explorer options -> advanced tab -> under the security section of settings uncheck integrated authentication.

share|improve this answer
    
Tried that, but then I'm unable to login at all, afterwards. –  user2903 Sep 13 '11 at 15:23
add comment

This doesn't exactly meet your original requirements, but I use firefox for this.

share|improve this answer
    
Lol, same thing i wanted to do but IE is a requirement since sharepoint only supports ie and sp1 adds chrome to the mix. So no firefox for me. –  user2903 Sep 13 '11 at 17:22
2  
Firefox is a tier 1 browser just like IE in 2010 RTM. –  PirateEric Sep 13 '11 at 17:47
add comment

Changing your IE settings just prohibits your browser from passing authentication, if you truly want to be secure and prevent pass through authentication you need a different solution.

share|improve this answer
add comment

If I remember well, you can go to /_windows/default.aspx to logout and visit the site anonymously.

share|improve this answer
    
That path "/windows/default.aspx" doesn't exist. –  user2903 Sep 14 '11 at 19:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.