Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

SharePoint Health Analyzer has detected the following error:


People search relevance is not optimized when the Active Directory has errors in the manager reporting structure.

Title : People search relevance is not optimized when the Active Directory has errors in the manager reporting structure.

Severity : 2 - Warning

Category: Configuration

Explanation : In Active Directory, only company leaders should have the 'manager' property set to NULL. As a result of errors, the Active Directory can incorrectly have the 'manager' property set to NULL for other users that can cause a decrease in people search relevance. By specifying the actual leaders of the company, these inconsistencies are not taken into account and the relevance problem is corrected.

Remedy : Specify the company leaders explicitly. Use the following PowerShell commands: $upap = Get-SPServiceApplicationProxy [appid]; Add-SPProfileLeader $upap [Domain][UserName]. Run 'Get-SPProfileLeader $upap' to check whether the leader was successfully added. As a last step, run a full crawl on the content source containing the start address (URL) of the user profile application. For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=2401800".

Failing Servers :

Failing Services : UserProfileService

Event Viewer Error :

Source : MSSQL$SHAREPOINT

An exception occurred while enqueueing a message in the target queue. Error: 15404, State: 11. Could not obtain information about Windows NT group/user , error code 0x534.


How do I remove this error?

share|improve this question
    
Just dumping an analyzer message isn't productive. –  PirateEric Sep 13 '11 at 14:51
    
If you would like people to answer a question for you, please put in some effort rather than copying and pasting an error message. See our FAQ for more general guidelines. –  Alex Angas Sep 14 '11 at 5:21

3 Answers 3

The error message is quite clear: you have several persons in AD that does not have defined the Manager property. SharePoint uses this to determine managers, colleagues, social distance etc. So it is a good idea to have this property set.

You can always disable a rule in the health monitor if you dont want warnings or errors in event log

share|improve this answer

You can use a PowerShell script to manually specify the leader, using the following code from this blog:

$upaProxy = Get-SPServiceApplicationProxy 7643a5c2-a6ae-49eb-8ba0-de2f32a890ba
Add-SPProfileLeader -ProfileServiceApplicationProxy $upaProxy -Name "contoso\davism"

Of course, you would need to substitute the correct application proxy ID and username. You can get a list of your application proxy IDs by running the Get-SPServiceApplicationProxy command in PowerShell.

share|improve this answer

Or you should not worry about the ID whatsoever and do the following:

$upap = Get-SPServiceApplicationProxy | ? {$_.typename -eq "User Profile Service Application Proxy"}

Add-SPProfileLeader -ProfileServiceApplicationProxy $upap -Name "Domain\Username"

This however assumes that you have a single user Profile Service application proxy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.