SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working on website with following settings:

  1. One site collection, uses language variations
  2. 2 Web Applications. First is used for administration (using Windows-Kerberos auth), running on HTTPS. Second is extended web app (using Forms auth), using HTTP and HTTPS.
  3. In one of language variation web i have a web (say "ABC") which must run on HTTPS (ensured by custom HTTPModule). Other webs run on http by default.

In SSP i defined 2 content sources: Contentsource "A" for public web (http) and "B" used only for web "ABC". These two contentsources are configured that one is excluding other, so results from one content source are not mixed with second.

Then there are 2 scopes, again one for public web and second for web "ABC". Each has rule that it must use only one content source (public web scope uses only contentsource "A" and excludes "B" and vice versa).

Crawl account has FullRead access. Content source "A" is indexing properly, but "B" indexes nothing. I have checked MOSS logs, EventLog but cannot find anything what is causing this.

share|improve this question

For Sp 2007, I had to setup another virtual directory that is mapped to my main sharepoint virtual (you do all of this through central admin) and this second virtual didn't have https turned on. Basically you tell your indexer to index this new url (ours was site:8080) and then in the server name mappings, you tell it when it sees your search only virtual to replace the server name with your real site address.

share|improve this answer
up vote 0 down vote accepted

Solved by setting "Specify forms credentials" section in Crawl rules for mentioned HTTPS login url.

What i don't understand why account with FullRead access cannot access site?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.