Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a custom field based on SPFieldUrl. What I want, is basically just a normal Url field functionality, but I don't want it to be visible when new item is added to the list (a webpart is filling it). The problem is, i cant see the value on the default view of this list, but when I edit the items, I can see that the value is set correctly

heres my xml definition:

  <FieldType>
    <Field Name="TypeName">NonEditableLinkField</Field>
    <Field Name="ParentType">URL</Field>
    <Field Name="TypeDisplayName">Non Editable Link Field</Field>
    <Field Name="TypeShortDescription">programaticaly set url</Field>
    <Field Name="UserCreatable">TRUE</Field>
    <Field Name="Sortable">TRUE</Field>
    <Field Name="Filterable">TRUE</Field>
    <Field Name="ShowInNewForm">FALSE</Field>
    <Field Name="AllowBaseTypeRendering">TRUE</Field>
    <Field Name="FieldTypeClass">MyProject.NonEditableLinkField,$SharePoint.Project.AssemblyFullName$</Field>
  </FieldType>

NonEditableLinkField.cs has nothing but constructors at this moment. Perhaps anyone knows where the problem is?

share|improve this question
    
Why create a custom field instead of setting ShowInNewForm to false on an instance of SPFieldUrl? –  Rich Bennema Sep 12 '11 at 15:15
    
well i ended up doing it this way, I was looking here, and somehow missed the 3rd option before –  matt137 Sep 13 '11 at 6:22

1 Answer 1

Have you actually checked that the field is checked as Display in the view you are using?

share|improve this answer
    
yup, the field was visible on the view, there was just no values in rows –  matt137 Sep 13 '11 at 6:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.