Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I need to create a simple list with an AD user column but when I try to add a new item I get an 'Unexpected error' if the username has been checked, if the username has not been checked and corresponds to a user in the AD I can proceed and it saves correctly.

The unexpected error message is:

System.InvalidOperationException: Namespace prefix 'xsd' is not defined. at System.Xml.Serialization.XmlSerializationReader.ToXmlQualifiedName(String value, Boolean decodeName) at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderDictionaryEntryArray.Read1_Object(Boolean isNullable, Boolean checkType) at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderDictionaryEntryArray.Read2_DictionaryEntry(Boolean checkType) at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderDictionaryEntryArray.Read3_ArrayOfDictionaryEntry()

Which doesn't help me much..

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Spre3,

I had the same problem and for a long time there were no answers out there for anybody. Then I saw the question hotfix for problem with SharePoint PeopleEditor in IE-9 and a person there had posted an answer that led me in the right direction. You could try his solution or mine, which I also posted as an answer to that question.

Regards,

Matt

share|improve this answer
    
You deserve more likes for spreading this article. –  AlexanderMP Oct 8 '13 at 19:29
add comment

I've run into the same issue. Your pages probably tell IE to use IE9 standards, i.e. you have a

<meta http-equiv="X-UA-Compatible" content="IE=9"/>

tag in your master page.

The problem is, this doesn't work with people picker. Please see this discussion: http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/90b3835c-6754-4bb6-9fd4-b74f16f236ff.

I haven't found a fix yet, just saw the workaround mentioned in the discussion -- i.e. you have to go back to using IE8 standards. That's not a good option for us, because we'd like to use CSS3.

share|improve this answer
    
jaleikas, please follow the link in my answer, there is a solution there. –  Matt Apr 24 '12 at 14:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.