Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When crawling my content I get the following error:

"45 https://something.com/sites/dcio Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled. "

The service account I am using has full read access to the web application.

I tried adding the DisableLoopBackCheck DWord to the registry, I added it to all my servers, and deleted the index, restarted them, crawled and still I get the same error. I used this guide

I am really curious about where this error is coming from.

share|improve this question
    
When you say the account have full read access, are you referring to permissions within the site or user policy permissions from the web application in Central Administration? –  John Chapman Sep 14 '11 at 15:39
    
@John Chapman, i mean i have added the user that runs the service to have full read permissions on the web application. I also added this to the main post –  nldev Oct 3 '11 at 9:33
    
Well two things are usually the ones I started from when I hit these errors. 1) Add an inclusion rule for the site into the Crawl Rules and 2) Can you login to the site, using the Crawl Account, and see the content? –  MichaelF Oct 3 '11 at 13:02
    
@ MichaelF what exactly do you mean by adding an inclusion rule? Do you mean a rule that includes the site in the crawl, because i thought that this was accomplished by adding the site to the content source? –  nldev Oct 3 '11 at 13:15
add comment

6 Answers 6

The content access account is not same as search service account. You can check the content access account on the Search Administration page, see System Status section. Make sure this account has read permissions on your web application.

Also you can change this account on the same section.

share|improve this answer
    
It has, the account is SP_Service, this account also has full read permissions on the web application... Any more ideas? –  nldev Oct 17 '11 at 14:12
    
It has what? SP_Service is a domain account? –  Amit Kumawat Oct 17 '11 at 15:54
    
The content acces account, SP_Service, has read permissions to the web applications. It is a domain account. –  nldev Oct 18 '11 at 6:47
add comment

Make sure the content access account has read access to the content databases: http://technet.microsoft.com/en-us/library/cc263445.aspx

The content access account...

Must have Read Access to the content being crawled. Full Read permissions must be granted explicitly to content that is outside the local farm. Full Read permissions are automatically configured for content databases in the local farm.

share|improve this answer
    
The content acces account has full read acces on the web application. How do you mean giving full read acces to the content databases? In SQL ? –  nldev Oct 17 '11 at 14:13
    
In SQL you grant the content access account the db_reader role on all content databases. This should be done by default, but if the order of steps were missed or if something else went wrong it may not be set. –  Mike Oryszak Oct 17 '11 at 14:20
add comment
up vote 1 down vote accepted

Oke, it turns out this being caused by our ISA server. We use the ISA server for load balancing and fail-over. This is something that SharePoint does not compute! When I turned the indexing server into a new WFE and added all applications to the host file pointing to the localhost, all the error messages disappeard!

I searched the internet for ages looking for an answer, i hope this one can spare someone from that experience.

share|improve this answer
add comment

This article might help to troubleshoot your issue..

http://kalashnikovtechnoblogs.blogspot.in/2012/02/troubleshooting-crawl-issues-for-ssl.html

share|improve this answer
1  
Please explain HOW your blog post will help, for example by adding an example, and then link to your post. We like to have the solution available in our forum instead of somewhere outside where we cant control the content –  Anders Rask Feb 17 '12 at 15:46
add comment

I also had a similar problem where my "Full Read" policy was in place, but when I logged in as the service account I still got "Access Denied" screens in some places...

Turns out this was due to my drafts settings. Since the service account didn't have edit, and drafts were visible only to editors, they weren't being indexed.

For now, I'm changing the user policy to "Full Control" but I'm hoping to find a better solution if there's one out there.

share|improve this answer
add comment

This Solution worked for me:

You need to disable the LoopBackRequest in registry. To do this, just follow my instructions:

  1. Go to command window and type regedit.exe
  2. Once opened the registry editor, just navigate to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa"

  3. Right click on "Lsa" and create a new 32bit DWORD value

  4. Rename it as "DisableLoopbackCheck" (Note: you cannot rename it actually. so, once created the DWORD value, directly paste/type as "DisableLoopbackCheck".

  5. Then again modify the value of "DisableLoopbackCheck" as "1"

  6. Close the registry editor.
  7. Now start to crawl the content.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.