Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm currently stuck trying to edit a Site Page - When I try to open the page, I get the following error:

soap:ServerServer was unable to process request. ---> A Web Part with this ID has already been added to this page.

I've tried to rename the file or simply 'download' a copy without any luck (sitePages download is disabled)

Anyone ran into this issue? I'd like to recover the file and be able to edit the page to remove the issue.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

For those interested, I found somewhat of a solution - Every time a file change is made, a 'history' version is made - I simply used the Version History window and loaded the file from a previous save.

There's probably a more elegant solution to this, but this worked for me.

As an FYI this will create a 'new' version of the file, with the old content in it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.