Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to follow some tutorials for customizing a list with InfoPath 2010. However, when I click on a list it appears I am missing the InfoPath button. I do have Infopath 2010 installed and can open it from the Start Menu. However, I cannot figure out how to customize existing list forms using Infopath.

Does anyone know what I could be missing? enter image description here

share|improve this question
add comment

5 Answers

There are a couple reasons it may not be displaying:

  1. You're not running the Enterprise edition of SharePoint. This feature requires Forms Services, which are only available in EE.

  2. You're looking at a list type that does not support this feature. Basically, any list type that uses a non-standard display for an item, like Calendars, will not have this option enabled. Surveys would probably be another one.

share|improve this answer
1  
My guess then is Forms Services not being enabled. I'll investigate this and get back. Thanks! –  JR_ATLDev Aug 25 '11 at 17:11
add comment

I had this same issue and was pulling my hair out. I had to go to Central Admin, Upgrade and Migration, Enable Features on Exiting sites, Check this box "Enable all sites in this installation to use the following set of features:" It then pushed down the features to my site and I then had the InfoPath Button in the customize list group in the ribbon.

I'm not sure why I had to do this, I created a new webapp and site after the features where enabled on my farm months ago. Also everything looked right everywhere I looked.

Oh well this is what solved my issue.

share|improve this answer
add comment

I had the same issue. I check Site features and Activated SharePoint Server Enterprise Site features but that didn't change anything. I then checked Site Collection Features and found: SharePoint Server Enterprise Site Collection features Features such as InfoPath Forms Services, Visio Services, Access Services, and Excel Services Application, included in the SharePoint Server Enterprise License.

Activating this feature on the Site Collection made the Infopath Customize Form button immediately appear on the List ribbon.

share|improve this answer
    
Brian P's solution worked for me as well. Simply activate Enterprise Features on the site collection and the button should appear in the ribbon. I would vote up his response, but apparently I lack the contribution points to do that. –  Adam O Sep 17 '13 at 12:56
add comment

It should be in the Customize List section of the ribbon as shown below. Make sure you click on the List Tab once you've navigated to the list.

enter image description here

share|improve this answer
    
Yes, it is not there. It appears to be missing on my ribbon with the list tab selected. Screenshot added. –  JR_ATLDev Aug 25 '11 at 13:30
add comment

Rob is correct - do you have Enterprise licensing? Check to see if you have Enterprise first, and if you do, then check to see if the Site Collection and Site Enterprise features are activated. However, Forms Services is not something you activate - you either have it or you don't.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.