Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a custom field type. I have added the field in a list and added a new item through it. Display mode also shows the value perfectly. But when I edit that item and my field is in edit mode it is rendering as if it was getting rendered in new mode.

I have created a filtered lookup column that is two list boxes. Any idea where I am going wrong?

share|improve this question
    
When you say you added a "custom field" does that mean Field Type, or does it mean you added a custom Site/List Column? –  Mike Oryszak Mar 11 '10 at 1:14
    
I am talking about custom Field Type over here...I have created filtered lookup column... –  Anonymous Mar 11 '10 at 1:22
add comment

1 Answer

You are creating a custom field type and control by the sound of it. So somewhere within the logic of your custom field control, you need to inspect the value of

this.ControlMode

This value will be an enumeration of SPControlMode and will tell you what mode the control is in. Use this to control what is rendered for the control in what mode.

It would help if you posted a code sample of your control and how your custom field type is defined.

share|improve this answer
    
yah I am using that for checking the display mode or not....but the problem was in set method of my field..anyways thanks for replying.. –  Anonymous Mar 12 '10 at 2:04
    
If anyone runs into same situation lemme know... –  Anonymous Mar 12 '10 at 2:05
    
Amit if you have found the problem then please share it. You can answer your own question. –  Charles Lee Mar 12 '10 at 8:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.