Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a Visio Web access web part which is pointing to a visio web diagram in my document library. Every time I save my visio web diagram, the user receives the message:

"Refresh Disabled - Enable refresh if you trust the contents of this file"

(sorry, can't post image as I don't have enough rep points) There are two buttons within the message -

  1. Enable (this session)
  2. Enable (always)

Even if 'always' is click, subsequent saves of the web diagram will bring up the message again. How to I stop this message from appearing after modifying the web drawing?

My visio access web part has a value of 1 minute in the "automatically refresh interval", but I have tried other values too, like zero. My data source is just a sharepoint list within the same site collection. I tried to add a trusted data provider, and an application ID (via the Secure Store Service) but these made no difference. I've also tried to update some of the Visio settings in the Office Customisation Tool (and run the wsp) but this made no difference either, since it is rendering in the browser.

I'm not sure where my answer lies, but I find it hard to believe there isn't a way around this. The user should not have to see this message.

Any help would really be appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Check out Chris Hopkins' blog post here, it should answer your question:) His blog is a great one to follow!

http://blogs.msdn.com/b/chhopkin/archive/2010/09/28/force-data-refresh-for-published-diagrams.aspx

share|improve this answer
    
Jessica - you have made my week! Thanks a mil. I'd seen this guy's blog before. He is quite the Visio guru. I'd up vote ya if I had the rep points! –  Anthony Kasses Aug 23 '11 at 22:35
1  
While this may theoretically answer the question, we prefer inclusion of the essential parts of the answer here, and to provide the link for reference. See answer for general guidelines. Thanks. –  SPDoctor May 29 '12 at 8:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.