Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

wondering if I configured something wrong.

I just installed SharePoint on my laptop and it's running very slowly. It seems to be stuck at the Logging Correlation Data step. What exactly does this mean? That my hard drive is too slow? I've tried disabling health analytics logging but no result.

Many thanks.

share|improve this question
    
Step can take up to 10 seconds by just navigating the pages. Untill it's cached, then things run faster. –  Chromanin Aug 18 '11 at 18:32
    
Did you install Foundation or Server? How much memory and disk do you have? Have you looked at the performance monitoring tools (e.g. Task Manager). What CPU and how many cores? –  SPDoctor Aug 19 '11 at 11:16
    
Well, I installed foundation on the machine together with DNS service, ADS, SQL Express 2008 r2. The machine does not really seem to do anything, memory and cpu usage are low on all levels. The system is a Sandy bridge 2720QM with 8 gigs of memory so I reach the minimum requirements easily. –  Chromanin Aug 19 '11 at 15:14
add comment

2 Answers 2

up vote 1 down vote accepted

Turn on the devloper dashboard and see if you can spot some oddities and report back.

stsadm –o setproperty –pn developer-dashboard –pv on
share|improve this answer
add comment

Based on what you have said, it sounds as though something is wrong. The only recommendation I would add for your setup is to get an SSD. But it should work acceptably on your system as it stands. I run SharePoint Foundation on a much lower spec. laptop, although admittedly I am using local accounts rather than running AD.

Don't forget that a 10-20 second wait for a page is perfectly normal the first time your web app wakes up if it hasn't been used for a while. That's not a caching issue, it's just the process starting up. After that your pages should load normally.

Are you sure it is the logging step that is taking the time?

share|improve this answer
    
Thanks for the input. Unfortunately it can be 10 seconds for each page request after the initial load. But it's only for the initial page request, but it goes for every single page. I have done another reinstallation on another partition, and this time when I try to install with nothing but the prerequisites + Founation I get an error at the applying updates step of the installation procedure. –  Chromanin Aug 19 '11 at 20:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.