Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Migrated a customized MOSS2007 Publishing Site to SharePoint 2010 using the dB attach method. Things mostly work and the content is all there. However I get "Object Reference not set!" in red near the top of all pages. Can switch the masterpage, standard or custom - doesn't matter and the error is still there.(when accessing site as an Admin user)

ULSVIEWER tells me: "Exception in file C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\Layouts\EditingMenu\SiteAction.xml: Object reference not set to an instance of an object." Hmm... isn't that a no touchy out of the box file. OK something to do with SiteActions menu.

When I compare the SiteActions menu items in the original site (2007) to the migrated site (2010) several menu items are not present on the migrated site. Also the exception only occurs if the user can see the Site Actions menu on the 2010 site.(Admin User) If I login as an under-privileged user, I don't see the Site Actions menu and the exception does not occur.

Any Ideas?

share|improve this question

1 Answer 1

OK, did a little digging with Google and found a link which helped: http://www.networksteve.com/enterprise/topic.php?TopicId=26140

To get rid of the exception I went to the site home page, then navigated to;

SiteActions > SiteSettings > Site Actions > Manage Site Features

and DEACTIVATED the SharePoint Server Publishing feature.

share|improve this answer
    
Please, mark your question as answered. –  Wictor Wilen MCA MCM MVP Aug 16 '11 at 16:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.