Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Has anyone had any success getting rid of this prompt? We're running MOSS 2007 SP2, and virtually all clients are IE8, and this dialog pops up when downloading any non-Office format document from a document library:

This occurs on our XP and Win7 clients and seems to be generated by the "SharePoint OpenDocuments Class" ActiveX Control. The message goes away when this control is disabled in the add-on manager, but then we lose the ability to open documents for editing. Is there any way to retain that functionality but eliminate the warning message when the user doesn't have edit permissions?

Edit: The "confirm after downloading" checkbox mentioned below eliminates this dialog:

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

I've fixed it, or at least worked around it in a way that seems to solve all of our issues. When I added PDF icon support to our server, I used the following XML in the C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\XML\DOCICON.XML file, as suggested in the linked KB article:

<Mapping Key="pdf" Value="pdficon.gif" /> 

But this document also specifies an OpenControl attribute for many file types, and when it appears it's either empty, or contains "SharePoint.OpenDocuments":

<Mapping Key="docx" Value="icdocx.gif" EditText="Microsoft Office Word" 
    OpenControl="SharePoint.OpenDocuments"/>

or:

<Mapping Key="chm" Value="icchm.gif" OpenControl=""/>

As it turns out, that OpenControl attribute is what governs how the browser is told to open the document; either using the SharePoint.OpenDocuments IE add-on, or using the browser's default handler for that type if the attribute is blank.

The key in this case is that if the attribute is missing, SharePoint defaults to telling the browser to use the add-on, which displays the warning message. Simply changing that element in our file to

<Mapping Key="pdf" Value="pdficon.gif" OpenControl="" /> 

and recycling the application pool fixed the problem for us. All of our documents are either PDFs or Office docs, and the add-on doesn't show the warning message for Office docs as long as the SharePoint site is in the user's Trusted Sites zone.

share|improve this answer
1  
To me that sounds like a bad way of acheiving what you want - you are basically turning off the Sharepoint functionality for a file type just to get rid of an annoying prompt. There has to be a better way - in Windows XP you could disable this through the Folder Options/File Types dialog. Microsoft seem to have hidden that in Windows 7 - but where? –  dunxd Dec 11 '12 at 14:38
add comment

protected by Alex Angas Jun 27 '11 at 3:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.